IRC channel logs

2024-11-10.log

back to list of logs

<sneek>Yey! mwette is back
<duncan>these things come and go, e.g. RDF comes in and out of fashion
<graywolf>Hello :) I want to create a object to compare against using eq?. It will be used as a value for default argument of a getter function, in order to be able to tell whether I got the stored value or the default.
<graywolf>How would I go about that?
<civodul>graywolf: you can do anything; for example ‘list’ and ‘cons’ and ‘string’ are guaranteed to return “fresh” objects, meaning they are not eq? to any other object
<civodul>so (define magic-value (list 'magic)) is enough
<graywolf>(list)... oh, right; I was so fixated on some hypothetical (make-object) I did not realize I can just use a list.
<graywolf>Thanks! :)
<civodul>check out https://dspace.mit.edu/handle/1721.1/5944
<civodul>it’s an eye-opener in many ways, and notably on the question of object identity
<graywolf>Will do :)
<johnjaye>the paper says it's about security in scheme 48. wouldn't have guessed it from the title
<ajarara>hello, I am trying to capture output from a process. I'm not sure why this returns the empty string (with nothing printed) while the raw system call (without being wrapped by the with-output-to-string macro) displays hello: https://bpa.st/NVKA
<ajarara>it's not a macro, huh. Otherwise why wrap in a no-arg lambda. But besides the point
<clarkf>ajarara: `with-output-to-string' sets the output port, which is basically guile-only. the docs recommend using `open-pipe' if you need to capture stdout/err
<ajarara>clarkf: thanks, I see that in the info pages now. those are the docs you're using, yeah?
<clarkf>yep!
<ajarara>thanks!