IRC channel logs

2024-10-11.log

back to list of logs

<wingo>good morning civodul
<civodul>hey wingo
<ekaitz_>civodul: what we talked yesterday, btw, I offer my time for help
<ekaitz_>there's not much I can do at the moment, but I can improve
<civodul>ekaitz_: much appreciated; we should take it as an opportunity
<ekaitz_>same with guix, i proposed myself as a commiter a while ago and here we are :)
<ekaitz_>things go slowly, but i'm stubborn
<civodul>ekaitz_: in Guix there’s a documented procedure, so normally that should work better no?
<civodul>if not, ping the maintainers and/or the folks vouching for you
<ekaitz_>I followed that!
<civodul>i’m happy to vouch for you if i haven’t already :-)
<ekaitz_>civodul: i sent an email to you, to janneke and efraim
<ekaitz_>and all said ok i think
<civodul>ok, could you check with maintainers what happened?
<civodul>it could be that one of us forgot to email them, or that they forgot themselves
<civodul>(Artyom got commit rights recently; it took a couple of weeks, which is not particularly fast, but it worked)
<ekaitz_>i'll talk with them, thanks!
<ekaitz_>hi! how can I test only one test in the guile codebase?
<mwette>when you build, there is a script, `check-guile', that is generated: use it as `check-guile 00-initial-env.test' etc
<ekaitz_>oh! thanks mwette
<ekaitz_>let's try that
<mwette> /list
<morenonatural>is ~/.guile only loaded for repl? if so, is there an init file for my shell scripts (basically, any `guile` command/process)?
<old>morenonatural: script never load ~/.guile, but you can manually do it in your script if needed
<dthompson>would be alarming if it loaded that outside of a user repl context
<morenonatural>I wanna have sort of a commons module that any of my (rather short) scripts can make use of by doing like (use-modules (my cool-stuff))
<morenonatural>any recommended way? leaving it in a ~/.my-guile-libs and modify env vars?
<morenonatural>... I still don't quite get a good grip of guix, so I wanna avoid it for now
<old>morenonatural: I'm not sure to follow here. You want to load a config file or want to load a module used by your application?
<morenonatural>old, a module used by my application
<old>Then you need to have your module installed in one of the %load-path
<old>can you can simply use the `use-modules' form
<old>oh I see, you want a work around for now
<old>here is a modified version of `load-user-init': https://paste.sr.ht/~old/4d5008060ca6b70944d0787b3aec7afc3b32e10c
<old>put your module code in ~/.guile-my-init, then call `(load-my-init)' at the top of your script
<old>That ought to work, but you will have access to private symbols and won't be able to rename (e.g. add prefix) to bindings
<morenonatural>old, I'll take a stab at it... thx
<morenonatural>...figuratively speaking: I'm not planning to stab anything or anyone for the time being
<rlb>ekaitz_: and though it's not ideal, see the top of check-guile for a tiny bit of info.
<rlb>(invocations, etc.)
<ekaitz_>rlb: thanks!
<ekaitz_>rlb: also I made this thing: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=73188
<ekaitz_>it's getting long to have some review or ideas on it, could you please take a look?
<rlb>Hmm, sorry, given my current pile, I don't think I'm a good candidate right now (mostly tied up atm with a serious bug elsewhere, and some debian work), particularly since I know almost exactly nothing about the PEG bits (never touched them). (I do expect things may get better in "weeks", fwiw.)
<ekaitz_>rlb: no pressure, I just was told yesterday you are doing a great job
<rlb>ACTION blushes
<ekaitz_>:)
<ekaitz_>any idea of who can I ping?
<rlb>Right now I also tend to be fairly conservative (overly?) with any merges, i.e. unless I think I understand things "well". I'm quite likely to wait for Andy or Ludovic, until/unless they'd want me to be more aggressive (and then of course, time would be the more significant factor).
<ekaitz_>let's wait for them then, but I don't want this to be forgotten in time... that would be a shame
<ekaitz_>(it has happened before to me, in guile)
<ekaitz_>in fact, i'm trying to revive my RISC-V port of lightening, but I need some help with a segfault we have... even if I'm passing all the tests
<ekaitz_>i think that will require some of wingo's help
<dthompson>speaking of lightening... I think there's a patchset out there that fixes a bunch of issues on windows
<dthompson>like making the jit work.
<dthompson>unfortunately no one has reviewed it and the author is probably disinterested now
<ekaitz_>dthompson: you know who the author is right?
<ekaitz_>of lightening you meant or of the patch set?
<ekaitz_>dthompson: OH but the windows compatibility changes are supersimple!
<ekaitz_>it's just a macro definition...
<dthompson>"we" should probably just merge it and say thanks for the patch
<dthompson>ekaitz_: I meant the author of the patches, not wingo :P
<ekaitz_>yeah
<ekaitz_>i don't expect that patch to break anything
<dthompson>I haven't tested or anything but I would really like to have a guile build for windows with working jit
<ekaitz_>we could try to push this a little bit
<ekaitz_>i'm trying to test the riscv port (i have some rv hardware)
<ekaitz_>i don't know how to test it properly but I'll manage
<ekaitz_>with that we can put some love in lightening...
<dthompson>sounds cool to me :)
<ekaitz_>we have to make it as easy as click "merge"
<ekaitz_>but someone has to
<dthompson>you mean get rid of debbugs? ;)
<ekaitz_>lightening is still in gitlab ;)
<mwette>ekaitz_: did you look in libguile/lightening/tests ?
<ekaitz_>mwette: if those are the ones on the library alone, yes
<ekaitz_>if there are more, looking right now after i build guile with it
<ekaitz_>oh yeah they are the same, it passes them all
<ekaitz_>but segfaults :)