IRC channel logs

2024-09-30.log

back to list of logs

<mwette>civodul: ppc is big endian by default, I believe
<cpli>is there a library which makes interacting with conventionally-packed structs comfier?
<cpli>oh there is! https://github.com/TaylanUB/scheme-bytestructures
<daviid>cpli: fwiw, there is a new one, proposed by mwette, here https://www.nongnu.org/nyacc/cdata.html
<cpli>daviid, that looks like a much better fit for ffi, thank you!
<daviid>welcome, thanks mwette ...
<mwette>thanks for the ack'; here is info on the ffi helper: https://www.nongnu.org/nyacc/nyacc-fh-ug.html
<daviid>dsmith: i think we should add a bot entry for ffi-helper and one for cdata, wdyt
<mwette>the ffi-helper has just been converted to use cdata; documentation is a little behind
<daviid>both would mention the other ofc ... so we could either ask about cdata? or ffi-helper? ...
<rlb>ACTION can't see those guix builds -- just get a 504...
<rlb>e.g. for https://ci.guix.gnu.org/eval/1677083
<rlb>I *can* see one further down (30 hours ago): https://ci.guix.gnu.org/eval/1674278 -- but that doesn't have any 32-bit powerpc builds that I can see?
<rlb>Unless civodul was just saying "lots of other things look fine".
<rlb>wingo: ^
<dsmith>daviid, Sure! What should those be? Just need to tell the bot
<daviid>dsmith: i think we should ask mwette what would be best, i just suggested ... so anyone of us can either ask the bot ffi-helper? or cdata? and both would link to both ...
<lloda>guile-procedures.txt patch looks good 👍
<cpli>mwette: if i wanted to dynamically rename symbols generated by nyacc ffi helper, is there some way to apply a renamer lambda on an arbitrary module?
<dsmith>mwette, Is there a better link for cdata than https://www.nongnu.org/nyacc/cdata.html ?
<mwette>cpli: there is a #:renamer option, but I have not tested it.
<mwette>dsmith: I don't have one better than that.
<mwette>Maybe the nyacc project page: https://www.nongnu.org/nyacc/
<mwette>I will work to update.
<mwette>cpli: in examples/cairo.ffi look at the commented-out #:renamer option; I just tried, it's not working ... looks like an infinite loop somewhere
<mwette>I'll work on it.
<mwette>renamer is working
<mwette>cpli: I released nyacc-2.00.5 w/ renamer working see examples/ffi/cairo-rn.ffi https://download.savannah.gnu.org/releases/nyacc/nyacc-2.00.5.tar.gz
<mwette>cpli: I reread your question. The generated code from the FH compiler is a guile module. Guile modules can be imported with a renamer. See the manual. I don't see why it would not work.
<Arsen>so I reckon it is fair to do a little bragging now; guile support in gentoo is damn-near finalized - now one can install multiple guiles, and guile libraries for some or all of them, as well as guile scripts or guile-integrating programs (like gdb or make), on the same level of effectiveness as python!
<sneek>Welcome back tohoyn :)
<dthompson>Arsen: awesome!! :)
<tohoyn>daviid: Is it possible to import callback types? I have tried "(import-by-name "Gtk" "CustomMeasureFunc")" but it returns #f.
<sneek>Welcome back tohoyn, you have 1 message!
<sneek>tohoyn, ArneBab says: Guile 3.0.10 does not build on every architecture of Debian yet. But AFAIK fixes are in the works (or already committed).
<tohoyn>daviid: sorry if I made a stupid question. Procedure types or callback types are not Scheme objects.
<tohoyn>daviid: but it would be useful to get a <callback> object using the name of the callback
<rlb>...testing main on s390x to see how a different big endian arch fares (wrt the powerpc failure).
<morenonatural>does guile have decimal-or-digit separator?
<rlb>s390x is fine
<rlb>morenonatural: perhaps (ice-9 i18n) number->locale-string
<rlb>Though only if you want to render the whole number I suppose.
<rlb> https://www.gnu.org/software/guile/manual/html_node/Number-Input-and-Output.html
<rlb>oh, right
<morenonatural>rlb, I wanted them for the code, rather than rendering them
<rlb> https://www.gnu.org/software/guile/manual/html_node/Accessing-Locale-Information.html