IRC channel logs

2024-09-29.log

back to list of logs

<mwette>test logging ...
<mwette>it's back now, thanks to nckx
<mwette>dialup: the material since it stopped is lost; so if you had a question may want to repeat it
<nckx>Sorry 'bout that, I'll try to upload the missing parts tomorrow (it's literally inserting lines in a text file so not something I'll do on a touch screen). Always feel free to ping me about such things.
<mwette>nckx: got it - and thanks!
<nckx>I don't see an obvious guest account asking something 'yesterday night' (whichever TZ than might be) though.
<dialup>Maybe it didn't go through, I just had a question about how to run the (web server) http server in a separate thread, I was able to get it to run in a thread but it does not stop after I execute a (stop-server) function that changes a flag because the (serve-one-client) call is blocking
<dialup>(define* (run-server-threaded loop?-box handler
<dialup> #:optional (impl 'http) (open-params '())
<dialup> . state)
<dialup> "Customized standard web server to run in threads."
<dialup> (let* ((impl (lookup-server-impl impl))
<dialup> (server (open-server impl open-params)))
<dialup> (begin-thread
<dialup> (let lp ((state state))
<dialup> (if (atomic-box-ref loop?-box)
<dialup> (lp (serve-one-client handler impl server state))
<dialup> (close-server impl server))))))
<dialup>That was the function I was asking about
<graywolf>Hello guile, is there a growing bytevector type? For strings, I can use call-with-output-string, is there something similar for bytevectors?
<civodul>graywolf: hey! there’s ‘open-bytevector-output-port’
<graywolf>Oh, precisely what I need, thank you :)
<graywolf>Is it in general acceptable for guile procedure in standard library to spawn new threads on behalf of the caller (if it is documented)?
<graywolf>I am thinking about how to handle (with-output-to-string (lambda () (system "date"))) and would like to upstream the result, however it will likely involve threads
<rlb>wingo civodul: as you may have seen, main may still have some 32-bit issues (exposed by testing on https://db.debian.org/machines.cgi?host=perotto) -- see the list thread. ATM I'd guess he was using a 32-bit chroot or similar. Offhand, I don't know if that was big or little endian, but I suspect the former.
<rlb> https://lists.gnu.org/archive/html/guile-devel/2024-09/msg00024.html
<civodul>rlb: https://ci.guix.gnu.org/jobset/guile is rather happy, but there’s no big-endian 32-bit target there (what would that be anyway?)
<civodul>ACTION -> zZz