IRC channel logs

2024-09-22.log

back to list of logs

<apteryx>hey Guiler! Anyone interested in having SRFI 64 properly documented in the Guile manual? If so, please review bugs.gnu.org/71300 :-)
<apteryx>Also, did you know about peek? I didn't when I started hacking on Guile, and being undocumented it took some time before I learned about it. Luckly someone has taken to document it: https://bugs.gnu.org/71684
<ArneBab>a
<ArneBab>sneek: later tell apteryx: I’m on it. For the first time with debbugs (Which is awesome! Why can’t I manage all my bug trackers like that?)
<sneek>Okay.
<ArneBab>sneek: botsnack
<sneek>:)
<cpli>what's the easiest way to call into libc from guile?
<cpli>it feels as though it should be possible without dynamically linking libc at runtime.. it's already there, isn't it?
<ft>I think calling dynamic-link without arguments gives you a library handle to libc.
<cpli>ft: is that documented anywhere q-q
<cpli>but yes, it seems
<ArneBab>sneek: later tell apteryx: you should have mail ☺
<sneek>Okay.
<ArneBab>sneek: botsnack
<sneek>:)
<ft>cpli: I don't think it is. I am not sure where I got it from. Someone may have told me. I've checked where I used it, and a comment in there mentions, that it gives you a library-handle with all visible symbols at the time "dynamic-link" is called, which likely contains all of libc.
<ft>But yeah. I don't have a reference for that.
<cpli>Q-Q i'm currently trying to get a proper monotonic clock, since (srfi :19) uses gettimeofday
<mwette>cpli: the posix section has get-internal-real-time, which uses clock_gettime(CLOCK_REALTiME, &ts)
<ane>what is the guile-procedures.texi file used for in doc snarfing of guile itself? I understand the guile-procedure.txt is used for documentation in the repl, but what is the texi used for?
<mwette>Can the `lib' argument to foreign-library-function be the object returned by load-foreign-library ? Otherwise, what is the purpose of load-foreign-library?
<mwette>I just tried it: `lib' can be a library object (string also allowed).