IRC channel logs

2024-09-21.log

back to list of logs

<ArneBab>sneek: later tell dthompson: I got into problems with chickadee and readline: chickadee play --repl text.scm (the simplest example) ⇒ (import (ice-9 readline)) ⇒ type a ( ⇒ segmentation fault.
<sneek>Got it.
<ArneBab>sneek: botsnack
<sneek>:)
<dsmith>sneek, botsnack
<sneek>:)
<mwette>sneek, botsnack
<sneek>:)
<ArneBab>cwebber: I just added wisp--eval-block (C-M-x) to the wisp-mode which copies the current block into a shell buffer. That works beautifully when having a live REPL to chickadee open in *shell*.
<ArneBab>cwebber: I thought that could interest you.
<cwebber>:O
<cwebber>ArneBab: very interesting
<cwebber>wait
<cwebber>oh
<cwebber>ok I got it
<cwebber>that's a bit alarming though maybe? maybe you could execute something unexpected
<ArneBab>cwebber: yes, it’s a bit risky and may need some tightening, but it works like a charm for a chickadee-game that provides a telnet-repl.
<ArneBab>cwebber: but you’re right: having *shell* as default may be a bit too risky — maybe I’ll have to get rid of the default and query for the buffer at the first call (and not only if the buffer does not have a process).
<cwebber>ArneBab: it's an interesting hack for sure :)
<cwebber>probably not the experience we want to provide though!
<cwebber>ArneBab: I still think the hacks I made were the best "experience" I have had
<cwebber>the ones that would wisp2lisp and push over to geiseer
<ArneBab>cwebber: those were wesp--eval-with-geiser, right? (that’s merged)
<cwebber>oh was it?!
<cwebber>I totally forgot, way cool
<cwebber>I think so...
<umanwizard>Hello. I'd have expected this snippet to return a string with my current username. Why doesn't it?
<umanwizard>(call-with-output-string
<umanwizard> (lambda (port)
<umanwizard> (spawn "whoami" '("whoami") #:output port)))
<umanwizard>instead it returns the empty string and also prints "whoami: write error: Bad file descriptor"
<ArneBab>cwebber: … but I had forgot to note it in NEWS ⇒ it’s in there now. Thank you!
<ArneBab>s/forgot/forgotten/
<ArneBab>cwebber: the default is now gone: you’ll have to select a buffer to send the code to.
<mwette>umanwizard: I played with it. I think #:ouput port needs to be file port.
<mwette>sad
<mwette>But I can guess why allowing all ports would make the implementation difficult.
<umanwizard>I see
<mwette>I created a container class for Gtk+-2 by subclassing, all in Scheme. No C at all. Just using the FFI-Helper to provide structures and procedure bindings.
<mwette>The entry is `packer-get-type'. snippet of code : https://paste.centos.org/view/40b1375e
<mwette>My single-button hello-world app works with this.