IRC channel logs

2024-09-15.log

back to list of logs

<mwette>I'm working on a major update to ffi-helper. would C-code as string to sexp be useful? (ccode->scheme "typedef struct { int x; double y; } foo_t;") -> '(define foo_t (cstruct '((x int) (y double))))
<chrislck>sneek: botsnack
<sneek>:)
<dpk>mwette: a C parser, capable of extracting #define and struct definitions and function declarations, portable to multiple Scheme implementations, would be very useful to very many Schemers
<sneek>chrislck: Greetings :)
<mwette>dpk: exists, currently translates "ffi-modules" to guile modules: https://www.nongnu.org/nyacc/nyacc-fh-ug.html
<mwette>I am wondering if converting smaller parts will be good. I will work on it. Also, I'm changing from bytestructure to my own "cdata" format.
<mwette>here is demo, where all the (ffi foo) modules are generated automatically fro include files: https://paste.debian.net/1329449/
<apteryx>Could someone review/apply the patch for bug #67255 (https://bugs.gnu.org/67255) ?
<apteryx>It's been authored by Timothy and reviewed/manually tested by myself
<apteryx>hm, I'm debugging something odd. The test I wrote in "bug#66046: [PATCH v4 2/3] tests: Add new compile-file tests." (see: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=66046#56) fails on the first ever run, and never ond the 2nd and subsequent ones.
<apteryx>also, to retrigger the failure, I haven't found another way than 'git clean -xfdd', rebuild guile and run the test.
<apteryx>OK, it has to do with auto-compilation
<apteryx>If I run the test with --no-auto-compile, it always fail
<apteryx>the error is: ERROR: compile-file: relative include works with load path canonicalization - arguments: ((misc-error #f "could not open any of ~S" (("./hello/hello-impl.scm" "./test-suite/./hello/hello-impl.scm")) #f))
<mwette>sneek, later tell dthompson: my cdata package: https://www.nongnu.org/nyacc/cdata.html
<sneek>Will do.