IRC channel logs

2024-09-09.log

back to list of logs

<robin>mwette, ooo. how are you getting that kind of size reduction?
<mwette>robin: I believe the reduction comes from eliminiating the "fh" type later over bytestructures.
<sneek>chrislck: wb!!
<sneek>dsmith: Greetings :)
<dadinn>hi all
<dadinn>I want to execute a shell function, but by setting an environment variable similar to `WORD=HELLO bash -c 'echo $WORD'`
<dadinn>execlp would allow me to keep the path, and execle would seemingly allow for setting environment.
<dadinn>I would also like to get back the error code, similar to how `system` procedure does
<dadinn>`(execle "bash" (cons "WORD=HELLO" (environ)) "bash" "-c" "echo $WORD")` does not work, because seemingly it doesn't use the PATH
<dadinn>The error is: "In procedure execle: No such file or directory"
<jpoiret>dadinn: there's spawn as well that you can use
<jpoiret>exec is only part of what you would want, since you first need to fork
<wingo>civodul: excellent bug report on https://issues.guix.gnu.org/72936 and my apologies!!!
<wingo>guess we should roll a 3.0.11
<wingo>(and i should fix it)
<civodul>wingo: hi! yes, i haven’t taken the time to investigate yet
<civodul>but yes, we should release 3.0.11 with that fix
<civodul>there’s also this issue on 32-bit platforms: https://issues.guix.gnu.org/72215
<ray1729>dadinn: I was playing around with a macro for this: https://github.com/ray1729/ordo/blob/main/modules/ordo/util/process.scm#L16 There's also an example in there of using spawn.
<ray1729>dadinn: with this macro, you can write: `(with-env '("WORD=HELLO") (system "bash -c 'echo $WORD'"))`
<old>sneek: later tell dthompson nice blog post about propagators for web UI!
<sneek>Okay.
<dthompson>old: thanks :)
<sneek>dthompson, you have 1 message!
<sneek>dthompson, old says: nice blog post about propagators for web UI!
<dthompson>sneek: botsnack
<sneek>:)
<morenonatural>hey, guilers... how do I parse a float from a string?
<leah2>(string->number "3.14")