IRC channel logs

2024-07-27.log

back to list of logs

<Aarush>sting-append works in the guile repl but not while running a .scm file; code is "(define (greet name)
<Aarush> (string-append "Hello " name "!"))
<Aarush>(greet "Aarush")
<Aarush>" it gives nothing as output.
<Aarush>Please help
<pukkamustard>Aarush: the greet function does not print anything to the console it only returns the appended string. Try (display (string-append "Hello" name "!")).
<dckc_>how do I make a weak map?
<dckc_> https://srfi.schemers.org/srfi-126/srfi-126.html looks promising...
<dckc_>aha... https://www.gnu.org/software/guile/manual/html_node/Weak-hash-tables.html
<mwette>dckc_: check vhashes in guile manual
<mwette>sorry that's not it ...
<mwette>weak hash tables: section 6.17.3.1
<mwette>di