IRC channel logs

2024-07-26.log

back to list of logs

<lampilelo>when guile is loading a file, is there a procedure that, on evaluation, stops the rest of the file from being loaded?
<old>lampilelo: Throw something?
<old>Or wrap the file with a prompt
<lampilelo>i don't want other files from being loaded, just the one
<lampilelo>let's say it's a library file
<lampilelo>an i have some prototyping remnants at the end
<rlb>lampilelo: if you're talking about something like perl's __END__, then I don't think we have anything like that, but as mentioned, if you're loading the file yourself (i.e. not down in the process of resolving modules), you could perhaps throw an exception of your own that you catch and "suppress".
<lampilelo>if there's nothing like what I described than nevermind, doesn't matter that much, but thanks for the suggestions
<ArneBab>Can you help me load-test the dryads sun Guile game server? I’d need about 30-100 people who open 10 tabs each with https://dryads-wake.1w6.org/sun to see whether it survives. And close after about 10 minutes. (I optimized it, so it can reap local data when a tab gets closed, and there are now three instances running behind an nginx server).
<orva>Silly question: does guile have helper functions for piping bytes from one port to another or is "read into bytevector and write that into output" the way to go?
<ArneBab>i.e. for i in {1.10}; do icecat https://dryads-wake.1w6.org/sun ; done # or for i in {1.10}; do firefox https://dryads-wake.1w6.org/sun ; done
<ArneBab>(this is running on a single CPU, so the multiple instances don’t actually provide more processing power, but multiple instances may enable me to add hot-replacement by first rejecting connections on one instance and once the existing connection finished, restart with the new version
<ArneBab>)
<ArneBab>correction: for i in {1..10}; do icecat https://dryads-wake.1w6.org/sun ; done # or for i in {1..10}; do firefox https://dryads-wake.1w6.org/sun ; done