IRC channel logs

2024-07-25.log

back to list of logs

<freakingpenguin>If I have a function that takes two arguments, a and b, and want to conditionally insert them into a list structure, what's the cleanest way to handle that? At present I abuse splicing to "delete" them https://paste.debian.net/1324288/
<mwette>I do (let* ((t '()) (t (if b (cons b t) t)) (t (if a (cons a t) t))) `(div ,@t)) or write a little procedure to do that.
<kaizer>Quick question, why no foss scheme ai?
<kaizer>I thought this would be fun enough to work on at least?
<kaizer>Plus not to mention its free money...
<sneek>dsmith: Greetings!
<dsmith>sneek, botsnack
<sneek>:)
<dsmith>!uptime
<sneek>I've been a process for 3 days
<sneek>This system has been up 3 days, 1 hour, 7 minutes
<freakingpenguin>I struggled to use ... in macros for so long, stopped touching them for months, and used them on a whim today in a more complicated macro and it just worked.
<freakingpenguin>Spooky.
<freakingpenguin> https://paste.debian.net/1324347/
<freakingpenguin>It's as if they randomly clicked in my mind sometime in the past months when I was doing something unrelated and I didn't realize it until now.