IRC channel logs

2024-07-09.log

back to list of logs

<haugh>I'm trying to use syntax-parameterize with make-transformer-variable. I'm getting scope errors. In Racket, they have a macro called define-rename-transformer-parameter which appears to be specifically designed to circumvent a comparable issue. Now, I can barely describe my issue; I'm just wondering if anyone here has done this in Guile.
<haugh>I'm trying to pass a reference to an escape cont into make-variable-transformer so that I can call it in different ways depending on an unrelated form.
<haugh>I'm doing (let/ec esc-k (syntax-parameterize ((break (make-variable-transformer ...))) ...) and seemingly regardless of how I invoke esc-k inside the transformer I get "reference to identifier outside its scope in form esc-k"
<haugh>Currently trying to pass the cont dynamically...
<sneek>wb optimal :)
<graywolf>Is there a simple way to re-export all symbols from another module?
<rlb>graywolf: perhaps https://codeberg.org/lokke/lokke/src/branch/main/mod/lokke/ns.scm#L74-L77
<graywolf>rlb: Ah that looks simple enough, thank you.
<graywolf>rlb: Is that simple enough not to be copyrightable?
<dsmith>graywolf, Easy for you to say. I get "Codeberg is currently unavailable for technical reasons"
<graywolf>Took me ~5 reloads across 10 minutes to get it to load, so it is not just you :)
<dsmith>Soemthing is not happy: https://status.codeberg.org/status/codeberg
<haugh>Please put "unexpected syntax in form ()" on my tombstone
<ArneBab>haugh: ☺