IRC channel logs

2024-07-06.log

back to list of logs

<lechner>mwette / hi, i tried (let* ((name (compile (compile-peg-pattern ...))) other-patterns) ...) but it could not find 'name' in subsequent patterns
<dsmith>lechner, maybe paste what you have in a pastebin somewhere
<ober>How can I change initial heap size? GC Warning: Repeated allocation of very large block (appr. size 47271936): May lead to memory leak and poor performance
<ober>export GUILE_HEAP_SIZE=5000000000; works
<rlb>I suspect those warnings are coming from libgc (boehm), and may just be noise (i.e. not hurting anything) if you expected your code to be doing that. Looks like there might be a way to get boehm to stop it too, but no idea if we've exposed that offhand.
<ober>trying to optimize https://github.com/ober/kunabi-scheme/blob/main/guile.scm
<cpli>why doesn't lambda* have flag arguments?
<haugh>mwette, saw you were looking for multi-value conditionals a ways back there; for future reference, (cond ((values 1 2) < => euclidean/)) returns 0 and 1
<mwette>haugh: thanks!
<mwette>but (cond ((values 1 2) => (lambda args (apply + args)))) => 1
<mwette>I get it now. You need a guard for mv.
<mwette>cond ((values 1 2) (const #t) => (lambda args (apply + args)))) => 3
<rlb>Hmm, do we not currently have a way to change/restore the current thread's locale at the scheme level, i.e. (I think) via uselocale()?
<rlb>I'm assuming I'd (I'll) need that if I want to call something like getenv completely safely (i.e. using latin-1 so it can't crash(?) trying to encode a value that can't be represented in the current locale's LC_CTYPE).
<rlb>(If that's right, then I'll probably see about adding support at some point.)
<ober>does mit scheme have packages? e.g. json parsing/gunzipping
<ober>ACTION can't ever get the right channel
<elb>2024-07-06T16:48:06-04:00
<elb>/names
<elb>hmmm that was strange
<elb>I typed `dt` and hit tab, and ERC completed `current-date-and-time` and then inserted that text, but pressing enter didn't send it but didn't prompt again, and running /names sent both
<elb>ahhh appears to be a snippet thing?
<elb>either way, not guile
<elb>playing with haunt again and that accursed first-paragraph function ;-)