IRC channel logs

2024-07-04.log

back to list of logs

<lechner>Hi, is there a function like this anywhere in the Guile libraries? It can 'intersperse' PATH elements with a colon. Thanks! https://bpa.st/G62A
<chrislck>(define (intersperse a xs)
<chrislck> (cond
<chrislck> ((null? xs) '())
<chrislck> ((null? (cdr xs)) xs)
<chrislck> (else (cons* (car xs) a (intersperse a (cdr xs))))))
<mwette>wingo: also `make check' fails on posix.text when configure includes `--disable-tmpnam'; I trying to make a patch ...
<mwette>and failing
<flatwhatson>lechner: string-join is good for that, if your path elements are strings and you're building a string (eg. a PATH environment variable)
<lechner>flatwhatson / thanks, but does that work with gexps? https://codeberg.org/lechner/juix/src/branch/history/juix/deploy/guile-pam.scm#L84-L121
<flatwhatson>probably not!
<lechner>flatwhatson / thanks!
<cow_2001>i'm slowly going through tkdocs.com
<cow_2001>i wanna get it into guile in some fancy way
<mwette>cow_2001: I'm working on a "tk" type api in guile
<mwette>on top of gtk2, all in Guile Scheme
<cow_2001>oh
<cow_2001>waaait if you've just joined how do you see me? oh, the log
<mwette> https://paste.debian.net/1322250/
<cow_2001>mwette: nice!
<cow_2001>mwette: is there a public repository?
<cpli>chrislck & lechner: don't you actually just want string-join in this case though?
<dsmith>mwette, Nice!
<mwette>Not working yet, but getting there. may upload somewhere in near future
<mwette>gtkinter code: https://paste.centos.org/view/6bd15f5c
<mwette>example code to register a new gobject type starts at line 353
<lechner>Hi, why does this say "warning: possibly wrong number of arguments to `with-exception-handler'" (with-exception-handler (lambda (e) #f) (load "a") #:unwind #t)
<lechner>okay it's not a lambda
<lechner>and #:unwind? has a question mark
<lechner>okay, why does this say "In procedure stat: No such file or directory:" (with-exception-handler (lambda (e) #f) (lambda _ (load "a")) #:unwind? #t) How may I suppress that message, please?
<shawnw>Probably isn't finding the file a. Is it in guile's load path?
<lechner>shawnw / that's on purpose. i am trying to call all exceptions (and suppress error messages)
<mwette>Is there any cond-type form where `=>' can transfer mutiple values?
<mwette>I guess it doesn't make sense in the failure case. Never mind.
<mwette>rlb: I was able to build out of your repo fine. I'll see if I can make a patch next.
<rlb>Hmm, I forgot (again?) patch for what?
<mwette>I was trying to extract a "utf8" patch from your repo to apply to the 3.0.10 tarball dist, so peeps could try utf8 that way.
<rlb>Ahh, ok. That may not work if the prebuilt files are using the old string layout -- or rather, at a minimum, you might need a "clean" too.
<rlb>For the diff, are you just running a make dist in the branch, and then diffing the contents against the release archive's?
<rlb>(plus or minus a bunch of exclusions, I'd guess)
<mwette>looking for pointers; make dist sounds like a good plan
<rlb>Note that I believe our make dist won't work right now from a clean tree -- you'll need normal make first (at least).
<rlb>I tried to come up with a fix for that a day or so ago when working on the other fixes, but gave up for now -- it's another case where subdirs don't allow us to say that dist depends on some subdirs (afaict). prebuilt's dist target requires meta/guile, but there's no easy way to express that.
<rlb>(that I could see)
<rlb>But also didn't want to spend too much time on it.
<mwette>got it - thanks. I just wanted to take a shot. If it doen's work, no issue.
<rlb>Sounds good.