IRC channel logs

2024-06-29.log

back to list of logs

<cpli>is and=> part of any srfi?
<freakingpenguin>Are patches submitted to guile-devel?
<ober>can't find (ice-9 stat)
<rlb>ober: hmm, I don't know of any (ice-9 stat) -- where did you see it referenced?
<ober>ok thanks
<rlb>If you're just looking for (stat ...) that's built-in: https://www.gnu.org/software/guile/manual/html_node/File-System.html
<freakingpenguin>Is there a standard way to take an existing error of arbitrary type, add on an extra message to it, and throw the modified error? As opposed to raising a new misc-error via (error "foo")
<freakingpenguin>Assuming I'm in a error handler of form (lambda (key error) ...)
<cpli>they're exceptions, so you can just wrap them in make-compount-exception
<ober> https://gist.github.com/ober/b06d4f87885f77378139aa34f63c9858 can't figure out why decompress will work
<dariqq>Hi, I am playing around with libguile and would like to check whether a module is available to avoid the error when it is not. I have found resolve-module but i cant seem to pass the ensure option from within c?
<mwette>something like this? scm_call_3 (SCM_VARIABLE_REF (resolve_module_var), name, scm_from_utf8_keyword ("ensure"), SCM_BOOL_F)
<dariqq>This looks like the scm_maybe_resolve_module function in libguile/modules.c. Let me try if it works
<dariqq>scm_maybe_resolve_modules does work but i had to copy the code for convert_module_name to convert a module from char* to SCM. Is there be a better way?
<dariqq>solved this for now by converting to (list 'name) manually. Thanks for your help :)
<mwette>yw