IRC channel logs

2024-06-28.log

back to list of logs

<ArneBab>haugh: and=> is one of the hidden gems of Guile, as is srfi-26 cut (cut + 5 <>)
<haugh>26 is alright but I would really like a specializer that can mix evaluated forms with recursive descent into re-evaluated forms. The last time I took a run at it I hit the limit of my syntax-case but it's on the docket
<old>so, why don't we have bindings for Vulkan yet? anybody had a look at that?
<shawnw>Because nobody's thought of it or felt it important enough?
<shawnw>(That was in reply to cpli's earlier comment about => and if, not Vulkan)
<sneek>dsmith: wb!!
<dsmith>sneek, botsnack!
<sneek>:)
<dsmith>sneek, later tell civodul Might want to update the topic for 3.0.10
<sneek>Got it.
<sneek>wingo: or maybe you could
<elb>Hello all! I've been looking for a static site generator but not finding something I liked, and I was doing some guile work the past few days, and I got a wild hair to scope to scheme generators, and I'm pleased to have found Haunt. I love how un-opinionated it is!
<elb>(spinning up some pages on Haunt was _much_ more enjoyable than writing texinfo, which is what I paused to play with haunt)
<dthompson>elb: glad you are enjoying haunt :)
<elb>I'm glad you chose to share it :-)
<dthompson>:)
<elb>Hah, it looks like the flat pages builder was only added in February; maybe I've looked at Haunt before and passed it over because of that!
<wingo>dsmith: done :)
<stanrifkin>There is no bitwise-xor in guile?
<lampilelo>yes, in srfi-60 and (rnrs arithmetic bitwise (6)), but also built-in as logxor
<stanrifkin>lampilelo: thank you, that works
<elb>dthompson: not urgent, but I want to preview blog posts like you do on dthompson.us, so I yoinked your (first-paragraph), and ... I don't understand it. If you are feeling generous, can you explain why the second match clause (or (('p ...) etc)) doesn't just turn it into a fancy `car` in most cases? Or should it?
<elb>as far as I can tell that snippet is just being wildly copied and pasted to all haunt sites ;-)
<dthompson>elb: heh that code looks a little weird to me, too, looking back on it. I'd write it differently now. :)
<dthompson>I do not like that it does weird stuff with variable binding
<dthompson>nor that it uses reverse
<dthompson>I should write a clean version of this...
<dthompson>I'll chalk this up to not being good at 'match' yet
<dthompson>I think the intended behavior is that it selects all the sxml nodes up to and including the first 'p' tag
<dthompson>so if you had, say, a header image before your first paragraph it would include that, too
<dthompson>oof, it's also using ... in a way I do not like.
<dthompson>not my best work, let's just say that!
<dthompson>I will make a better version of this :)
<freakingpenguin>Haunt's quite fun. You can do some very weird stuff with it very easily.
<elb>dthompson: I'm actually 88.29% sure that making that `or` an `and` does the right thing
<freakingpenguin>Writing all my posts in raw SXML is a pain though. Sometime I might see what'd be required for readers that can eval escaped sexp's in a non-sxml document.
<elb>no, I lie, it does not, but I think the intent was that the or should have been and
<elb>freakingpenguin: there's a suggestion on awesome.haunt.page that one of the sources there allows scheme inside commonmark
<elb> https://git.sr.ht/~nybble/nybble-website/tree/main/item/nybble/reader/commonmark+scm.scm
<dthompson>elb: yeah it should be an and!
<freakingpenguin>Ooh, interesting. Thanks for pointing that out.
<dthompson>we need to fix guile-commonmark to allow html... that's been frustrating to not have
<elb>I think for me, the point is that while I see some things haunt doesn't do that I'm ultimately going to want, it's so small and _grokkable_ that I feel like I could do those things
<elb>like it took me two minutes to write a (probably wrong) symlink generator
<elb>versus something like [redacted] or [redacted] where I've spent 4,000 moltons trying to just friggin' suppress a paragraph break somewhere or whatever
<dthompson>oh good, glad you find it easy enough to hack. that's the whole point. :)
<freakingpenguin>Once you figure out the domain-specific terminology it's quite enjoyable.
<elb>yeah I can now (links '((src1 dst1) (src2 dst2))) in my site specification and it'll just create symlinks to other places on the filesystem or whatever, and it's 10 lines of scheme
<elb>I made an artifact and use the artifact, I'm not actually sure I should be doing that
<elb>It would be nice if the Haunt theme layout function had access to page metadata; I suspect it doesn't because previously metadata was associated with posts, not pages, but as of the flat-pages builder that has changed
<elb>(in particular authorship and license information are of interest to me)
<elb> https://lostbits.net/ :-D
<elb>The source repo isn't browseable, sadly, I don't have a quick static site solution for that, I don't intend to run any server-side web services there, and Mercurial hosting has become thin on the ground.
<dthompson>elb: yay your site is up :)
<elb>yeah it's still empty because spin-up yesterday, but progress ;-)
<freakingpenguin>elb: I like your banner art!
<elb>dthompson: btw I'm 99% sure now that the correct line 45 for your theme.scm is ((and (('p _ ...) _ ...) (paragraph _ ...))
<elb>note or->and and the addition of a _ after 'p
<elb>freakingpenguin: thank you! That's an 8-bit punched paper tape from a Teletype Model 35 KSR that says LOSTBITS.NET, with some of the chads scattered around it on a concrete floor
<dthompson>most, if not all, of those "..." things should go away
<elb>unfortunately the lens of the DSLR I used to shoot it is damaged internally so it has some annoying chromatic aberration, but I haven't yet had a chance to yoink a better lens/camera from my wife to re-take it
<elb>dthompson: I take no position on either that or whether it should use sxml-match at this time ;-)
<dthompson>I prefer regular match when it works
<freakingpenguin>I did read the first couple of letters on the punchcard. The bit ordering was a bit odd from my orientation so it took a second.
<elb>I tried removing some ...s but didn't have success, dove into the match documentation for a hot minute, and then just shipped it with the added _
<dthompson>elb: https://git.dthompson.us/blog/tree/theme.scm#n40
<dthompson>improved
<elb>freakingpenguin: yeah, that tape is oriented for insertion into the LPR on the Teletype
<elb>dthompson: oh ... duh, yeah, I didn't express it as a cons