IRC channel logs

2024-06-20.log

back to list of logs

<haugh>holy cow, I've been using guile for almost two years and I just realized you can quasiquote vectors!
<haugh>(let ((foo 'bar)) `#(baz ,foo)) ⇒ #(baz bar)
<haugh>apparently this is standard scheme, though I don't know where it would be in the spec
<apteryx>janneke: you may be interested in 'snarfi' for you next SRFI doc import task: https://lists.gnu.org/r/guile-devel/2023-12/msg00067.html
<cpli>is there any documentation on `set-pointer-finalizer!`?
<janneke>apteryx: ah, didn't know that; thanks
<janneke>ACTION used pandoc and an emacs macro
<janneke>apteryx: after removing <em>.. from <em>Programming Praxis</em>, it seems to loop forever (5min now)
<janneke>why oh why do they (only) supply the object format of the documentation and not the source?
<lloda>there's some configuration issue on logs.guix.gnu.org, sorry if already noted
<wingo>hoooo, very hard to not rewrite lots of the docs
<bjoli>wingo: Docs have a tendency to start behaving like tangled string. You start by changing something small in one end, and by the end of the weekend you have written 2000 words, where at least half of them were ached out
<bjoli>I was changing something internal at work recently, and by the end of the week the documentation was restructured completely and about 30% was completely rewritten.
<bjoli>(and this wasn't even technical documentation. It was union things, describing routines, hiring processes, documents describing formalities of different kinds. I didn't have to think very hard about which words to use). It started as a small edit of jury duty (for auditions, I am an orchestra musician), but then I had to edit something else
<bjoli>regarding the hiring process (and how the union is involved in the process to ensure fair play). From there it went quickly downhill.
<bjoli>wingo: what I wanted to say, if there are any small tasks that can be done by a classical musician with a limited grasp of english I would love to help. I have thought about porting irregex to guile (and of course the simpler srfi of it). I don't know if there is any interest for it though. I would probably just compile to PCRE and leverage the
<bjoli>existing regular expression facilities.
<dsmith>bjoli, I'm curious, what instrument(s) do you play?
<kjartanoli>bjoli: I thought guile-irregex already existed.
<cpli>if i only want a size-of buffer for a foreign function to write a struct to as an out-argument, do i have any alignment guarantees when using bytevectors, or should one simply use (make-c-struct types vals) and null it out manually?
<cpli>*a buffer with the size of a struct