IRC channel logs

2024-06-09.log

back to list of logs

<cpli>haugh: just for me, if i wanted matrixes by themselves i'd just use chickadee's matrixes
<taeaad>If you develop a Guile application, similar to developing one in Python, which you may sell as SaaS or by some other means, would you be restricted more by the license? Are there practical implications?
<taeaad>Do you have to share only alterations to core libraries?
<rlb>Not remotely legal advice, but the LGPL bits of guile may not limit you much there, but you'd need to do your own research with respect to your specific intent. FWIW, there's a (recently improved) attempt to track all the licenses in the debian/copyright: https://salsa.debian.org/rlb/deb-guile/-/blob/deb/guile-3.0/d/sid/master/debian/copyright?ref_type=heads (which debian requires).
<taeaad>rlb: Thanks. There is also this statement on gnu.org, which I consider fully logical, but perhaps open to interpretation, "Scheme level code written to be run by Guile (but not derived from Guile itself) is not restricted in any way, and may be published on any terms. We encourage authors to publish on Free terms."
<lechner>Hi, how may I implement, in Guile, a callback procedure with this C signature? int (*conv)(int num_msg, const struct pam_message **msg, struct pam_response **resp, void *appdata_ptr);
<lechner>nvm, i just found the qsort example
<lechner>With Nyacc's FFI, may I use 'struct-ref' to write to the underlying bytestructure? I tried (bytestructure-set! (struct-ref conv 0) 'conv ptr) but got "Cannot write value with this bytestructure descriptor." Thanks!
<mwette>not sure about context, but check fh-object-set!
<mwette>I've been running into issues w/ callbacks and other fh stuff. Been working on it in the dev-1.10 branch.