IRC channel logs

2024-02-29.log

back to list of logs

<jmes>Hey, I'm trying to create and connect to a Unix socket but I'm getting connection refused: https://bpa.st/FTWA - not sure what the issue is.
<jmes>I want to test writing and reading some bytevector data over a Unix socket.
<jmes>Okay after some hair pulling I found out that I'm able to connect if I make the socket a SOCK_RAW type (not SOCK_STREAM). But I need a SOCK_STREAM for my use case...
<mwette>Do you have gnutls extension? You'll need that for https I believe.
<mwette> https://gnutls.gitlab.io/guile/manual/
<jmes>mwette: If your question was directed at me, I'm just working locally and not using HTTP or TLS
<jmes>It's for Wayland wire protocol messages
<jmes>Which should use SOCK_STREAM (according to what emersion told me yesterday). Anyway, I'm able to do some testing and development at the moment with SOCK_RAW but it may be an issue later
<rlb>jmes: not at all sure, but what's on the other end when you try to connect? Also, are all the fs permissions "fine"?
<mwette>jmes: See https://github.com/mwette/guile-wl-play
<mwette>I did 100% wayland client app in guile
<mwette>well, except for the mmap and sockmsg apis
<mwette>here is my connection: https://github.com/mwette/guile-wl-play/blob/main/demo15#L848
<tohoyn>has the Guile bytecode file format changed since version 3.0.0?
<apteryx>daviid: if you can wait a little bit for the release of guile-lib, I think I can add a commit on top + a small bug fix to improve things further
<daviid>apteryx: i am waiting you to fix the devel branch actually, it still not on https://git.savannah.nongnu.org/cgit/guile-lib.git/, and any git attempt on that branch, which i still have here, fails 'no such 'refs/heads/devel' ...
<daviid>i wrote bout this here a few days ago ... but you didn't see i guess
<daviid>i have no idea why you deleted it, wwitout even asking, and/or why you said there were no commits, everything i did since i maintain guile-lib occurred on the devel branch 'first', then i merge and release when ready -
<daviid>maybe i should 'git push origin devel' from here, then you clone (a new clone), checkout the devel branch and apply your patches there, push then let me know ... the problem is i don't know if that would work 'as expected', since the branch i have here is already referencing 'refs/heads/devel' ...
<daviid>apteryx: i did that, as recommended by #git guru - please make a new clone, then git fetch --all, git checkout devel, apply and push those patches we agreed on, without 'extra metadata', and let me know, thanks
<apteryx>daviid: I don't mind to do so! sorry for deleting the devel branch; it was clear from Magit that its history had been fully merged to the master branch for some time
<apteryx>to recreate the devel branch as it exists from your side, you can 'git push --force origin devel' from your devel checkout
<apteryx>I'll then rebase my branch on it
<apteryx>it's weird, I have this successful push in my history: git … push -v --force-with-lease --force . improve-logging-library\:refs/heads/devel, exiting with status 0
<apteryx>ah, that refs/heads/devel was my mistake, that's local I think
<apteryx>anyway, repushed the series we agreed on (with a simple bug fix in the last commit), commit is da850d9 on the devel branch
<apteryx>daviid I confirm the commit are there now: https://git.savannah.nongnu.org/cgit/guile-lib.git/log/?h=devel
<apteryx>commits*
<daviid>ok, i got those now - problem solved. i'll wait for this improvment you were speaking about ... let me know (please paste a copy of the 'patch on top' before to push, just to make sure we agree, tx)
<daviid>going afk, bbl
<apteryx>it's this simple change: https://paste.debian.net/1309097/
<apteryx>I'm checking if it's possible to write a test for it
<apteryx>we have setvbuf, but is there a getvbuf or some way to check the buffering mode of a port?
<apteryx>seems like not (also no getvbuf in libc)