IRC channel logs

2024-01-28.log

back to list of logs

<ttz>rlb: mwette: thanks, I think I get what was wrong in approach: I just checked with (define t '((1 2) (1 2))) and then setting the car of the first list member... it modifies both members. So nothing wrong with the macro mwette posted. I still don't really understand why things are that way. I guess this is the evaluator trying to be clever in optimizing a constant. But this is not what one (at least me) would expect
<ttz> when writing such expression.
<rlb>wingo: ok, I've updated https://codeberg.org/rlb/guile/src/branch/rev-parallel-tests if you or anyone else would like to try to reproduce the "make -j5 check" hang in test-signal-fork. I have a vague guess that you might need a -j near or above your core count, but just a guess.
<rlb>oops, meant civodul ^
<rlb>wingo: though I've also updated https://codeberg.org/rlb/guile/src/branch/utf8
<rlb>Both are on current main.
<gabber>i am trying to create a macro that creates a string "var: value". so that `(define a 13) (debug-print-var a)' returns "a: 13". this https://paste.debian.net/1305588/ works for a single variable, but i'd love to have it work on multiple variables as well. how can i do that?
<gabber>i'd also be ok with something like (map debug-print-var (list a b c)) -- but this doesn't work either (obviously)