IRC channel logs

2024-01-23.log

back to list of logs

<graywolf>Can I somehow restart a computation from a specific frame in the Guile's REPL debugger after an error?
<sneek>janneke: Greetings!
<pinoaffe>graywolf: no
<pinoaffe>i believe that SRFI 249 would be a (relatively recent) request to implement something along those lines
<graywolf>Ah, interesting. I was watching a short video about common lisp today, and while I prefer scheme, this feature looked quite interesting.
<graywolf>I will keep an eye on this srfi.
<weary-traveler>graywolf: what was the feature in question?
<dsmith>And there is a Guile implementation too
<graywolf>weary-traveler: Restarting execution after error from some previous stack frame.
<graywolf>(in (f1 (f-long)), if you have a bug in f1, you can restart it after fixing the bug, removing the need to execute the long running f-long again)
<graywolf>At least that was the example showned. Not really something I would need daily (probably?), but can imagine it being handy.
<weary-traveler>ah resumable exceptions, iiuc
<weary-traveler>it's an essential building block for things like algebraic effects and handlers
<weary-traveler>i.e. if there's language support for it then your implementation can be much more efficient, because presumably you have built-in support for capturing slices of continuation frames (i believe some literature refers to it as meta-continuations, unless i'm misremembering)