IRC channel logs

2024-01-19.log

back to list of logs

<lispmacs[work]>you're going to make me hunt it out in the source, aren't you...
<lispmacs[work]>not sure where to start. if the debugger can extra source information, then I suppose the debugger code would be the place to start
<lispmacs[work]>but which file?
<lispmacs[work]>./system/vm/debug.scm
<lispmacs[work]>./system/repl/debug.scm
<lispmacs[work]>./language/tree-il/debug.scm
<lispmacs[work]>repl/debug sounds promising
<oriba>just playing around with http-head and http-get from web-client, what data type is it returning?
<oriba>currently I just need the return code to find out if a url is broken link
<oriba>it looks like "#<<response> version: (1 . 1) code: 200 [MORE STUFF] port: #<closed: file 760e2e0ef690>>
<oriba>but as currently learning scheme, this does not tell me how to extract the data
<oriba>looks like extension to scheme by guile
<dthompson>oriba: see 7.3.7 HTTP responses in the guile manual
<dthompson>response-code, for example, would return the status code
<oriba>dthompson: thank you! :-)
<dthompson>np :)
<oriba>ok, for http, this works fine, but for https, it does not work, I get err-msg gnutls-not-available
<oriba>in the guile-refman I didn't find tls mentioned
<dthompson>I don't remember all the details here but sounds like either your guile wasn't built with gnutls support or it can't find the gnutls shared library at runtime
<oriba>hmhh, ok
<oriba>looks like gnutls was not considered in building it... hmhhh
<ericcodes>I don't know why I can never remember this. Whats the function that dumps a value to stdout and returns the value. It is two characters and is used for print debugging
<old>ericcodes: pk
<old>alias for peek
<ericcodes>that's it, thanks
<apteryx>there's a patch documenting it on the tracker, IIRC
<apteryx>but as with other patches, it lingers, eh
<ericcodes>The last time I couldn't remember how to spell it, I had to watch a couple of Christine's videos to find it
<daviid>ericcodes: pk
<daviid>which is a shortname for peek
<lloda>when i paste a form feed char in my terminal, it pastes a 'symbol for form feed' instead which guile thinks is a symbol. It's annoying
<old>anyway to get the CLOCK_MONOTONIC in Guile ?
<old>other than using system foreigns
<graywolf>old: guile --use-srfi=19 -c '(pk (current-time time-monotonic))'
<graywolf>SRFI-19
<graywolf>I think that should be it?
<old>graywolf: oh nice
<lispmacs[work]>hi, I'm a little confused about how to use @ and @@. I don't seem to be getting the syntax right. Could somebody give me a working example of @@?
<lispmacs[work]>oh, okay, I see where I went wrong
<lispmacs[work]>nvm
<lilyp>lispmacs[work]: @@ is the rude version of @
<ieure>lol