IRC channel logs

2024-01-11.log

back to list of logs

<iank>i'm new to guile, how can write a hello world script that starts fast? < 20 ms. i web searched guile startup time, i came upon https://wingolog.org/pub/wingo-self-hosted-scripting-guile-morevms18-preprint.pdf
<iank>which says single digit ms startup time is possible
<iank>my current hello world takes 36 ms with guile 3.0.7-1
<iank>dumped onto a single line: #!/usr/bin/guile !#(display "Hello, world!") (newline)
<iank>oh, seems it liks 19ms about 4/5 times. that is pretty good. any tips on decreasing it more?
<cow_2001>lookit lookit! writing a dumb ol' RSV library https://codeberg.org/kakafarm/guile-rsv
<daviid>sneek: guile-software?
<sneek>Last time I checked guile-software is http://sph.mn/foreign/guile-software.html Send an email to tantalum, <sph at posteo dot eu> to make changes or post a new project.
<daviid>cow_2001: ^^ please send a mail to get your project added to the list, thanks
<cow_2001>huh!
<cow_2001>oh i have at least another thing i wrote using guile
<cow_2001>the other thing i use every day
<cow_2001>daviid sent! :D
<daviid>great - i am not the site mainainter, and ime sometimes it gets updated rapidly, sometimes it takes time ... just keep an eye and send a gentle ping if nothing happened in a wekk or so ...
<daviid>*maintainer :)
<cow_2001>oh, i need to set a license
<cow_2001>guix is gpl, guile is lgpl
<cow_2001>should i set it to LGPLv3+?
<cow_2001>oh no
<daviid>you should always prefer gplv3+, unless otherwise recommended [by someone who damn knows what their talking about and raises a good reason to propose lgplv3+ instead]
<cow_2001>what about agpl?
<daviid>cow_2001: when it comes to license(s), i am not someone who damn knows what they're talking about, but i see no reason why you would use agpl, just stick to gplv3+, unless otherwise recommended ... is what i think you should do, but ... do as you think you should ofc ...
<cow_2001>hmm
<lilyp>AGPL is useful if you expect your software to primarily run in a web context, but otherwise plain GPL is good
<singpolyma>These days all software can end up in a network context pretty easily so I default to agpl
<apteryx>how difficult to add a RUNPATH feature to the Guile's elf (.go) files?
<apteryx>would it be*
<apteryx>to avoid having to propagate Guile libraries globally
<apteryx>this would obliviate the need for all these pesky wrappers seen in Guix guile packages, or manually done in some projects.
<civodul>would be nice, but quite a bit of work i guess
<civodul>also, .go are optional in theory
<civodul>and the behavior would now depend on whether or not .go are available
<civodul>not sure if that’s a problem in practice tho
<apteryx>it'd be sugar added on top; if there's no .go, we're back to status quo
<apteryx>would at least be useful to Guix and packaging Guile programs in general
<civodul>yes, but then you have a situation where: if .go is available and fresh, dependencies are found; otherwise dependencies are not found
<civodul>(because there’s no RUNPATH in .scm files)
<civodul>in a Guix context it’d be great, i agree
<apteryx>A warning in the doc could explain this gotcha
<apteryx>What would be needed would be 1) write the RUNPATH metadata (perhaps via some flag given to guilec?) to the produced ELF and 2) Have Guile honor it when loading .go ?
<apteryx>s/guilec/guild compile/
<graywolf>If I would like to ask for a code review, should I just ping in each of the threads in the mailing list?
<apteryx>graywolf: good question. I guess it's good to try, but there doesn't seem to be much reviewers available.
<apteryx>with so little eyes watching, I'm also wondering if it wouldn't be better to send patches to bug-guile so they are registered as issues and less likely to fall in cracks than on the mailing list?
<graywolf>It does sound reasonable, but I don't really have an opinion, just patches ^_^
<apteryx>I guess the Guile maintainers have better tooling that I do to filter emails submission (a local archive of the entire mails with a tool to index/search within)
<lloda>i think for anything that needs followup, bug-guile is a lot better than guile-devel
<daviid>i can't access https://logs.guix.gnu.org/guile/
<cwebber> https://systemcrafters.net/courses/hands-on-guile-scheme-beginners/
<graywolf>lloda: Does that mean I should re-send the patches into bug-guile (I have no problem doing that)?
<graywolf>So I should understand it that bug-guile is for bugs and patches, and guile-devel for discussion?
<dsmith>daviid, I can get to the logs
<daviid>dsmith: ok, tx - i have a dns and packet routing problem with my internet provider ... i can't acces some sites (nor my email unless using tor ...))
<apteryx>lloda: such as patch submissions?
<apteryx>guix as two trackers to keep them separate: bug-guix and guix-patches; perhaps guile could benefit from the same
<apteryx>or if traffic is low enough just patches to bug-guix, which get marked with a patch tag may be fine
<apteryx>but the current contribution text in the doc suggests to send to guile-devel, which I why I was doing so
<ArneBab>iank: for lowest startup time, you’ll want to create a module and run it with shell-deferring, so it just loads the auto-compiled module from disk: https://www.draketo.de/software/guile-snippets#minimal-startup-time
<ArneBab>apteryx: I also send patches to guile-devel, but I wouldn’t mind doing it otherwise.
<iank>ArneBab, thank you!
<ieugen>hi, any guile libraries to work with google protocol buffers / gRPC ?
<ieugen>or put another way - are there popular artifact registries / indexes for guile libraries ?
<ieugen>* that will allow me to look for one ?
<ieugen>hmm, found one https://gitlab.com/joolean/r6rs-protobuf/
<dsmith>sneek, software?
<dsmith>sneek, guile-software?
<sneek>Someone once said guile-software is http://sph.mn/foreign/guile-software.html Send an email to tantalum, <sph at posteo dot eu> to make changes or post a new project.
<dsmith>ieugen, ^^