IRC channel logs

2024-01-08.log

back to list of logs

<wmedrano>drat, I went through the same thing with Haunt a few weeks ago. Wish I saved the instructions
<rekado>gnucode: I always do “autoreconf -vif”
<wmedrano>I think I had to set the GUILE_LOAD_PATH, touch some file, and run "autoreconf -vif"
<gnucode>rekado: that certainly helped.
<gnucode>./configure
<gnucode>configure: error: cannot find required auxiliary files: config.rpath
<rekado>is the .ac newer than the configure? (i.e. is the script actually regenerated?)
<gnucode>I could delete the configure script.
<gnucode>rm configure && autoreconf -vif
<gnucode>autoreconf: error: automake failed with exit status: 1
<gnucode>that's probably not a good sign.
<graywolf>Hello, is it still true that suspendable ports are much slower?
<graywolf>And, is there a way to check what ports do I have? I do not see suspendable-ports? procedure in the manual...
<civodul>graywolf: hi! if you don’t use Fibers and didn’t call ‘install-suspendable-ports!’, then you’re using the “regular” ports
<civodul>“much slower” is probably an overstatement though
<graywolf>Documentation states about 3x to 4x times if I read it right...
<civodul>oh, ok
<civodul>then i was being optimistic :-)
<janneke>civodul: re shepherd patch set, that was a LGTM; but you might be waiting for some feedback from others
<civodul>janneke: ah excellent, thanks!
<civodul>i’ll rebase and apply later then
<janneke>civodul: (y)
<sneek>Yey! dsmith is back!
<dsmith>sneek, botsnack
<sneek>:)
<rekado>I’m trying to write a little platformer game with Chickadee, with jumping, gravity, and collision detection, etc. I don’t want to overcomplicate things and reinvent implementations, though, so I wonder if someone has already written something like that with Chickadee.
<dthompson>rekado: I don't know of anything, but basic rectangle intersection in (chickadee math rect) should get you a long way
<dthompson>the (chickadee data quadtree) module could be helpful if you have a lot of collidable things to test against
<dthompson>(though the interface is kind of bad right now... :/)
<dthompson>rekado: I will say that doing things in a "bespoke" way that fit your game rather than trying to wrap a C physics library will yield a better feeling game.
<rekado>I’ve been using rect-clip / rect-intersect with the player’s hitbox and obstacles (including the ground), but I think I’ll have to use one rectangle per direction to determine whether to invert velocity in that direction.
<dthompson>rekado: yeah that makes sense. I should really implement an example basic platformer so I have some things to recommend for such a common use-case
<rekado>that would be great!
<dthompson>I just always end up doing something else...
<rekado>I’ll fiddle with my rectangles and see if it’s good enough
<dthompson>I am most familiar with top-down games that don't use platformer "physics"
<dthompson>top-down 2d rpgs, space shooters, etc.
<dthompson>I know I've seen some good info out there about how to do platformer physics in a nice way
<dthompson>to handle jumping up and through a platform but landing on it when going back down, etc.
<dthompson>ACTION has been working on the graphics layer lately
<dthompson> https://pool.jortage.com/tootcat/media_attachments/files/111/721/121/049/818/511/original/f3e97ceb95363c32.mp4
<dthompson>getting ready for a world where chickadee can run on the web via webgl/webgpu
<rekado>exciting!