IRC channel logs

2023-12-27.log

back to list of logs

<wmedrano>Regarding running tests on multiple threads. Calling scm_boot_guile for each test seems to do the trick. https://hastebin.com/share/ciqebegiru.rust
<wmedrano>No clue how unsafe it is 😅
<wmedrano>According to docs, this seems ok https://www.gnu.org/software/guile/manual/html_node/Initialization.html
<daviid>count3rmeasure: probably a 'false positive', the list that appear on guile's website is built automatically from the list of projects in guix (that use guile) - so that list is (largely) incomplete, and probably contains a few false positive ...
<count3rmeasure>ahhhh
<count3rmeasure>thank you daviid:
<daviid>count3rmeasure: welcome
<dsmith>sneek, later tell wmedrano What. Are. You. Doing!?
<dsmith>sneek, potsnack
<dsmith>sneek, botsnack
<sneek>:)
<dsmith>!uptime
<sneek>I've been aware for one month and 18 days
<sneek>This system has been up 38 weeks, 3 days, 6 hours, 33 minutes
<dsmith>sneek later tell wmedrano What Are You Doing!?
<dsmith>sneek, seen wmdrano
<sneek>I last saw wmedrano in #guile 1 hour and 19 minutes ago, saying: According to docs, this seems ok https://www.gnu.org/software/guile/manual/html_node/Initialization.html.
<dsmith>sneek later tell wmedrano What Are You Doing!
<dsmith>Hmm
<tomnor>Say two functions f1 and f2 like this:
<tomnor>f1: (lambda (a . b) ...)
<tomnor>f2: (lambda (x . y) ... (f1 x y))
<tomnor>Is there a way to "unpack" y in the call to f1?
<tomnor>I mean, in f2, y might be like (a1 a2)
<tomnor>And then in f1, b will be seen as ((a1 a2))
<tomnor>This is bikeshedding of course, but anyway
<jpoiret>tomnor: you can use apply: (apply f a b rest) will call f with argument list (a b . rest)
<jpoiret>it's variadic so you can do (apply f rest) or (apply f a b c d rest)
<tomnor>jpoiret: But yes! Thank you