IRC channel logs

2023-12-20.log

back to list of logs

<cobra>I'm using the foreign function interface, and a method I want to use takes a double pointer as an argument, but I only have the data as a list of 16-bit integers. How can I convert between the two?
<dthompson>cobra: you'll need to pack a bytevector with the data and use bytevector->pointer
<dthompson>list->f64vector might be useful to you
<cobra>dthompson: thank you!
<cobra>hm, I need to wrap a procedure in a mutex lock. Is that possible in guile?
<dthompson>cobra: see with-mutex and friends
<cobra>oh, thank you