IRC channel logs

2023-12-15.log

back to list of logs

<qookie>is there a function to generate the cartesian product of some lists in the standard library?
<apteryx>is it possible to quote a reader macro?
<apteryx>e.g. #~
<apteryx>I want to produce code as data, where #~ is potentially unknown
<isaneran>apteryx: seems like they get expanded before the quoting happens
<isaneran>however maybe you could locally bind it to override or something like that
<isaneran>but for producing code as data, wouldn't it be fine to produce it expanded to (gexp ...) ?
<civodul>just stumbled upon http://hop.inria.fr/home/texinfo.html
<civodul>(texinfo) compiled with Hoot, when? :-)
<dthompson>y'know... this kind of came up in the #spritely channel
<dthompson>some folks are having a hard time finding stuff in guile's html docs since texinfo's html export... sucks.
<dthompson>guile can parse texinfo... kinda. needs a few more things to parse a full manual.
<dthompson>but I don't think it's too big of a stretch to say that we could parse the whole manual with guile and generate a much better html manual
<dthompson>html export, that is
<fjl>dthompson: Hear, hear!
<dthompson>and with hoot, the manual could eventually have embedded REPLs to try out guile without installing anything
<dthompson>and of course we could incorporate some nice dynamic features that would otherwise had to have been implemented in js
<dthompson>someone is experimenting with at least some of this over in #spritely. we'll see what they come up with.
<dthompson>they're inspired by the Janet docs
<dthompson>as a step towards a guile repl in the browser, we just published a little something: https://spritely.institute/news/scheme-in-scheme-on-wasm-in-the-browser.html
<janneke>scheme in scheme, such fun!
<dsmith>While we are talking features, how about running all the examples in the manual to make sure they still work?
<dthompson>that would be cool, though would require each example to be completely self-contained
<dthompson>and have some sort of expected output to match against
<dthompson>a literate test suite of sorts ;)
<dthompson>guix does a good job of improving texinfo's horrible html export by post-processing it. we borrowed that technique for spritely's docs.
<dthompson>but it's obviously not ideal to have to clean up garbage
<fjl>I'm working at the moment on upstreaming some civodul's code from Guix to Guile proper and I'm making sure that all the examples in docs have matching test cases.
<dthompson>fjl: oh neat!
<fjl>BTW, minority of procedures in guile docs have examples and among them only some include @result{}
<dthompson>TIL about @result{}
<dthompson>had no idea
<fjl>Looks like there are multiple patterns used in examples. That's one of them.
<fjl>sometimes @example sometimes @lisp
<apteryx>sneek: later tell isaneran it seems to work with gexp/ungexp, thanks!
<sneek>Will do.
<cow_2001>is there a way of embedding scheme inside of skribilo?
<cow_2001>or maybe it's really that you embed skribilo inside of scheme with minimal boilerplate so that it feels as if you embed scheme in skribilo?