IRC channel logs

2023-12-07.log

back to list of logs

<euouae>Hey all
<euouae>I had some good fun today with Guile
<euouae>I did an AoC challenge Day 5 part 2 it worked out pretty nice
<euouae>but one thing that is bothering me is that I don't understand how to use the guile debugger when I get errors
<euouae>Is the guile debugger nice to use or is it work in progress?
<euouae>I'll look at the manual's contents more carefully on debugging
<haugh>euouae, be sure to check out 4.4.6, Interactive Debugging
<euouae>thanks
<euouae>hey all, can guile 3 compile to native executables?
<dthompson>euouae: no, unfortunately.
<dthompson>future work. perhaps guile 4 will...
<euouae>ah alright
<dthompson>compilation to webassembly is underway, though
<euouae>that's pleasantly surprising!
<dthompson>which should take care of some of the work needed for native compilation
<dthompson>but yeah, if you need native compilation *today*, something like chicken or gambit scheme might be the way to go
<euouae>I don't need it I'm just learning Guile
<dthompson>ah okay
<euouae>I recognize your handle from strigoform -- I'm the shadow tetris dev :P
<euouae>So I'm learing guile, yeah that's my task. There's some cool things in the Guile manual, I want to read some of the more technical stuff
<dthompson>euouae: ohhh! I thought your username looked familiar
<dthompson>cool, welcome aboard!
<euouae>ty
<mwette>euouae: for technical detail, try http://wingolog.org/tags/guile
<euouae>thanks
<euouae>unrelated question but I wasn't able to find info on this -- does guile have some general purpose functional library?
<euouae>e.g. I don't think I've seen `curry` anywhere and I had to implement my own `group-by-2` with unfold
<euouae>e.g. (a b c d) ==> ((a b) (c d)) or so
<euouae>also is there a sequence library? the vector/string stuff seems a bit awkward and ununiform
<euouae>e.g. vector-for-each is different to string-for-each, and string-for-each-index bizarrely seems to be a generic counting function
<euouae>or e.g. there's no vector->string so you have to intermediately translate into a listk
<mwette>Maybe the SRFI subsection on transducers will interest you.
<euouae>nice thank you