IRC channel logs

2023-12-06.log

back to list of logs

<psyleft>Hello, can anyone here help me debug a problem I'm having with a guile project
<psyleft>I'm using guile's run-server procedure and I can't access it from outside localhost, even though I have iptables rules set to allow and a hole in my firewall
<dthompson>psyleft: sounds like it's listening on localhost only
<dthompson>you'll want the server to listen on INADDR_ANY
<psyleft>Thank you, INADDR_ANY was exactly what I needed
<psyleft>I knew it had to be something simple
<dthompson>np :)
<graywolf>Hi! How can I convert a real number to an integer? (floor 1.0) still returns 1.0 instead of 1
<lloda>exact from (rnrs)
<lloda>or inexact->exact
<lloda>but note that (integer? 1.0) => #t in Guile
<graywolf>Oh, I did not realize that
<graywolf>Are the .go file architecture specific? Or portable?
<graywolf>In general, can I just copy them around between machines and expect that to work (assuming same guile version)?
<dsmith>graywolf, There are 4 flavors of .fo files. big/little endian and 32/64 bit. A little-endian-64bit .go should be the same on all little-64 bit machines
<dsmith>s/.fo/.go/
<graywolf>Thanks :)
<dsmith>graywolf, I *think* all 3.0.X are ABI compatible. Not sure.