IRC channel logs

2023-12-02.log

back to list of logs

<qookie>is there any procedure that implements a boolean and but is actually a procedure and not a macro (so i can use it in fold and apply and whatnot)
<qookie>or do i just roll it on my own
<rgherdt>qookie: you mean for something like (fold and '(#t #t 2)) ?
<rgherdt>you could use srfi-1 and write: (every values ...)
<qookie>something like (fold and #t '(#t #f)) or (apply and '(#t #f)
<rgherdt>(every values '(#t #f))
<rgherdt>values is the identity function in this case
<qookie>ah thanks
<rgherdt>I forgot the accumulator in my fold example before, but was what I meant
<rgherdt>yw
<qookie>actually i can probably simplify my code with every since the list for fold is produced by mapping over some other list
<rgherdt>there are lots of useful stuff in srfi-1
<apteryx>pinoaffe: re sxml-match doc, that sounds like a welcome improvement