IRC channel logs

2023-11-28.log

back to list of logs

<pinoaffe>the (sxml match) documentation is separate from all other sxml documentation in the guile docs - is there a reason for this?
<jelleke>howdy folks, I'm a relative Guile noob and have been learning Scheme for the past year. I'm now considering getting more serious and using it for work stuff. Do you know any static analysis tools I could use next to my typical unit/integration tests?
<isaneran>jelleke hmm apparently the guile-tools (now known as guild) command used to have a linter
<isaneran>but I don't know if there is that much more than the warnings from "guild compile" command these days
<isaneran> https://user42.tuxfamily.org/guile-lint/guile-lint.html
<jelleke>ok, I'll check it out
<jelleke>I'm thinking Guile would be perfect for all kinds of static analysis
<jelleke>since it's so easy to autoinspect
<isaneran>yeah
<jelleke>contract programming would also be pretty neat
<isaneran>It would be nice to have something like typed racket for guile as well
<isaneran>or maybe at least a static analyzer that does type inference where it can to try to detect errors
<jelleke>yeah, that's what I was thinking initially, you should be able to infer a lot of types
<isaneran>However it might make sense to make a language addon for a typed guile that basically copies typed racket stuff
<isaneran>Since you can already add compilers to guile
<isaneran>(see guile --language=ecmascript)
<jelleke>aah sweet, thanks for the tip <3
<jelleke>lol at the doc for ecmascript: https://www.gnu.org/software/guile/manual/html_node/ECMAScript.html
<jelleke>I bet the irresponsible person in question also wrote this, haha
<isaneran>probably haha
<rebiw>anyone using guile-sdl? I'm unable to use render-copy properly, even in the hello.scm example.
<rebiw>(render-copy ren texture  #:srcrect (make-rect 0 0 40 40) #:dstrect (make-rect 0 0 40 40))
<rebiw>In procedure write-c-struct: too few values (8 8 8 8)
<rebiw>The error does not clarify what is wrong with the render-copy call.
<dthompson>rebiw: any reason why you're using sdl1 and not sdl2?
<rebiw>I think that I'm using sdl2
<rebiw>yes it is guile-sdl2
<dthompson>ah okay
<rebiw>I'm trying to modify the example hello.scm
<dthompson>I wrote most of it
<dthompson>looks like a bug in some ffi operation
<rebiw>oh
<rebiw>I'm using guix to install the library, it is working fine for the most part.
<rebiw>I just had this issue with render-copy. I will try using it from source
<dthompson>probably will be the same result
<dthompson>backtrace would help
<rebiw>yes I tried using the backtrace but it goes into an infinite loop.
<dthompson>huh?
<rebiw>At least with geiser ( using comma and then b)
<dthompson>guile should just print out the backtrace when it crashes
<dthompson>you may be getting yourself into trouble with geiser
<rebiw>ah yes
<rebiw>I will post it in a pastebin
<rebiw> https://paste.debian.net/1299536
<dthompson>rebiw: thanks!
<rebiw>hope it helps
<dthompson>it does. now I know that this is a bug that has been fixed in the master branch.
<dthompson>commit 240dd224cccfbd224f1e770f1589d6124cf6bb1f
<rebiw>the regular render-copy works fine,
<dthompson>I should make a new release soon...
<dthompson>been about a year
<rebiw>ah cool
<rebiw>I checked the version, I had the latest
<rebiw>0.8 or something
<dthompson>yeah this bug fix commit is literally the next commit after the v0.8.0 tag
<dthompson>it's a slow moving project now since I have all the bindings I need but I try to make one release per year.