IRC channel logs

2023-11-27.log

back to list of logs

<apteryx>is there an interface to query the list of exported bindings from a module?
<spk121>apteryx: something like (hash-map->list (lambda (sym val) sym) (module-obarray (resolve-module '(srfi srfi-1))))
<ArneBab>lechner: AFAIK Guile only auto-compiles modules. Which is why running a script as a module has much lower startup time than running it as script: https://www.draketo.de/proj/py2guile/#sec-2-2-3-2-1
<daviid>ArneBab, lechner: to my knowledge and exp., scripts are compiled, unless you pass the --no-auto-compile option, i.e. - exec @GUILE@ --no-auto-compile -e main -s "$0" "$@" - which what we do (at least what i do) do when istalling script(s), in $prefix/bin, which merely use-modudles and start an app or call the main script core procedure ... to avoid the compilation warning, that each user would see ... for such tiny script, the
<daviid>start-up time is insignificant (none human perceptible) - ofc when you do this, all modules that the app or 'core script' defines would(must) have been (pre)compiled and installed in a location 'known' by guile, the guile ccache dir, or a dir in the GUILE_LOAD_COMPILED_PATH ...
<tdback>Hi everyone! I'm just jumping into learning Guile so I thought I'd say hello!
<lloda>|o
<sneek>dsmith-work: wb!!
<dsmith-work>sneek, botsnack
<sneek>:)
<dthompson>tdback: welcome!
<apteryx>spk121: thanks
<apteryx>does anyone know how to easily recreate the test-suite/tests/r7rs.test environment from a REPL?
<apteryx>using the top define-module doesn't work there, perhaps because the module name doesn't match the file hierarchy
<apteryx>am I supposed to be able to do things like: #:use-module ((scheme base) #:select (cond-expand)) ?
<apteryx>to shadow the core cond-expand syntax?
<apteryx>I can't seem to get cond-expand from (scheme base) available when the (test-suite r7rs) module is defined as #:pure
<apteryx>even if I #:use-module ((scheme base) #:select (cond-expand)) in the define-module declaration, or (import (scheme base)) below
<apteryx>if I drop #:pure, it works, so I'm puzzled
<apteryx>here's what I'm trying to test, and failing: https://paste.debian.net/1299438/
<apteryx>r7rs:cond-expand is exported as 'cond-expand' from (scheme base)
<apteryx>what breaks it is #:pure, though I don't understand why
<apteryx>I've asked about it on guile-devel