IRC channel logs

2023-11-25.log

back to list of logs

<lilyp>spk121: Pardon the joke, but: "With one simple patch, he got his software to build. Microsoft hates him!"
<spk121>lilyp: haha
<apteryx>can I use a syntax transform procedure, and later assign that to an identifier via define-syntax?
<apteryx>there seems to be some slight difference; the former (procedure) receives its argument as deeper list of items, while the syntax would be 'embedded' in the syntax matched
<civodul>apteryx: hi! one is supposed to only ever use ‘define-syntax’ with ‘syntax-rules’, ‘syntax-case’, or ‘identifier-syntax’
<sneek>civodul, you have 1 message!
<sneek>civodul, yarl says: : Hi, I saw that isc-dhcp is end of maintenance : https://www.isc.org/blogs/dhcp-client-relay-eom/ . It's known in the description of isc-dhcp by the way. I am wondering if there is plan to switch to something else as it is the default package for dhcp-client-service-type? Thank you.
<civodul>anything else may be questionable, because too low-level/dependent on internals
<apteryx>yes, I'm using syntax case
<apteryx>syntax-case*
<apteryx>I realize I can probably define it as syntax and use is as such, since I'm working within another piece of syntax
<civodul>ah ok
<apteryx>except not using it as syntax there, but as some general processing
<civodul>that’s ok, ‘syntax-case’ can be used for pattern matching on syntax objects
<apteryx>great; I'm getting a weird error about a top level define that is declared before my syntax not beingh defined
<civodul>then you need to make sure the procedures you need at expansion time are actually available at expansion time
<civodul>(that’s why ‘define-syntax’ guarantees)
<civodul>so maybe you’ll need ‘cond-expand’ here and there
<civodul>er, i mean ‘eval-when’
<apteryx>I'm in the process of defining cond-expand :-) I've moved its definition to r7rs-libraries.scm to refine it per R7RS additions
<civodul>oh :-)
<apteryx>that's what I'm trying to work from: https://paste.debian.net/1299234/
<apteryx>with the error at the bottom
<apteryx>the goal is to extend cond-expand itself then use it instead of the R7RS specific handle-cond-expand defined later
<apteryx>that way it's a top level definition and can be used anywhere with the R7RS features, as expected
<apteryx>basically addressing #65363, but also making it usable outside of the 'define-library' syntax
<civodul>ACTION is not really into R7 :-)
<apteryx>it's a really neat reorganization of the top level things + a nicer standard define-library (module support)
<apteryx>portable scheme looks easier than ever with it
<apteryx>I've been mostly dumping upstream SRFI R7RS libraries in Guile that were developed against Chicken or Chibi and they just work
<apteryx>(fixing R7RS bugs in Guile like the one I'm trying to :-))
<apteryx>the only friction is there documentation (the spec) is in HTML and often the tests are written using some implementation dependent style, which looks 98% like SRFI 64
<apteryx>their*
<apteryx>it seems to be some interaction with being in an 'include'd file
<apteryx>if I move it in the boot-9.scm parent source (just before it includes r7rs-libraries.scm), the error vanishes
<apteryx>also interesting is that using (pk 'something some-value) in there apparently causes: Wrong type to apply: #f