IRC channel logs

2023-11-15.log

back to list of logs

<mhcat>apteryx: is it just a case of proposing that the code in the srfi-197 be added unchanged as a module, to the guile-dev mailing list?
<mhcat>I guess I could actually go and read a contributing guide actually...
<festerdam>Is there some existing tool to generate an AST of a C program in the form of a sexp that's easily usable in guile?
<festerdam>Maybe I could use https://github.com/mjsottile/sfsexp, by writing a C program that uses that library to generate a sexp, store it in a file and have my scheme code read it.
<apteryx>mhcat: I'm no current Guile maintainer, but I assume so; including its test suite and ideally documentation translated to our Texinfo format.
<apteryx>I'm currently doing just that for a couple SRFIs, and have been working on a script that takes the HTML of a SRFI spec and outputs Texinfo from it
<festerdam>Nevermind, sfsexp only offers a way to parse and represent sexp expressions in C, and isn't used to generate ASTs of C programs (I don't know why I thought that it did).
<mwette>festerdam: nyacc, see https://git.savannah.nongnu.org/cgit/nyacc.git/tree/module/nyacc/lang/c99/parser.scm#n738
<mwette>it returns a sxml tree
<festerdam>mwette: That's really useful and exactly what I need. Thanks a lot!
<ron77>does anyone knows of a free tutorial on youtube for scheme/gulie/emacs for beginners?
<mhcat>apteryx: thanks, I will see what I can cook up
<mhcat>ron77: I don't know of a youtube tutorial as such, but Christine Lemmer-Webber has a good written tutorial that can get you set up https://spritely.institute/static/papers/scheme-primer.html
<mhcat>spritely, her org, is also a good source for excellent pedagogy - I also saw a link on there to a system crafters vid about goblins, which might also fit the bill somewhat (and they have a lot of emacs resources)
<ron77>i got a question which is silly but now do you add 'comments' to guile/scheme code?
<lloda>; comment till end of line
<lloda>see also http://community.schemewiki.org/?comment-style
<festerdam>Hi, all!
<festerdam>I'm trying to use the nyacc software (https://www.nongnu.org/nyacc/), I configured, «make»d it, and make-installed it, but I don't seem to be able to use the modules that supposedly would become available. At first I set it up with the wrong guile version and I'm struggling to configure it with the correct guile version, but even with the guile version configure correctly ran with, I don't seem to be
<festerdam>able to run «(use-modules (nyacc parse))». Guile tells me that there is no code for that module. What am I doing wrong?
<festerdam>make and configure when run with the wrong guile version didn't result in a printed error.
<parnikkapore>Hi! I'm wondering if you can use Haunt to output e.g. Gemtext sites
<festerdam>Ok, make install had this message «installing NYACC sources in NONE/share/guile/site». I don't think NONE is supposed to be there. Maybe I have to change the base directory where stuff is installed to.
<mwette>festerdam: try ./configure GUILE=/path/to/guile
<mwette>where /path/to/guile is the guile binary you want to use
<mwette>I'm getting the same thing. There is some bug in there -- YIKES.
<festerdam>mwette: Ah, I forgot the equal sign, that's why it failed to configure with a different guile version.
<festerdam>While it does use the correct guile version now, I unfortunately am still unable to «use-module» the new modules. The paths still have NONE in them.
<festerdam>Maybe I have to set --prefix?
<mwette>Can you try ./configure --prefix=/usr or whereever that should be?
<festerdam>Is /usr the default?
<Arsen>/usr/local is
<mwette>festerdam: where is guile binary?
<mwette>festerdam: type "which guile"
<festerdam>mwette: /usr/bin/guile3.0
<festerdam>Though «guile» (which is of the version I don't want to use) is at /usr/bin/guile
<mwette>As a workaround, you can use the source directory. cd to nyacc-1.09.9/examples and . env.sh (assuming you don't use csh). Sorry about this mess.
<mwette>I have to go away, but will work it in the next few days.
<mwette>so weird
<festerdam>mwette: Ok, setting the prefix to /usr worked! Thanks!
<mwette>festerdam: good to hear ; in examples/nyacc/lang/c99/tryit.scm are a lot of examples of me hacking on the output sexp's from the C parser.
<mwette>:q
<festerdam>ACTION thumbs up
<parnikkapore>can you use Haunt to output e.g. Gemtext sites?
<tohoyn>sneek: botsnack
<sneek>:)
<dthompson>parnikkapore: I've never done so but haunt is quite flexible so I think the answer is "yes"
<ieugen>hi, how do I reload / re-evaluate in repl, a guile module that I changed?
<ieugen>trying to upgrade clojure-tools. I started guix repl inside guix shell , buil clojure-tools. changed version, now I don't know how to re-eval the file so I can build again
<sneek>wb dsmith-work :D
<dsmith-work>sneek, botsnack
<sneek>:)
<ieugen>I managed to rebuild clojure-tools via REPL but can't test it since I can't install