IRC channel logs

2023-11-14.log

back to list of logs

<dsmith>apteryx, Cute name. I like it.
<apteryx>:-)
<apteryx>srfi 151 import completed!
<isaneran>sup guilers
<civodul>rlb: hello! have you been able to take a look at incoming patches lately? :-)
<civodul>(i haven’t!)
<mwnaylor>Does guile have a partial function? ex. (define plus5 (partial + 5))
<lloda>you can do (define (plus5 x) (+ 5 x))
<lloda>srfi-26 gives you (define plus5 (cut + <> 5))
<mwnaylor>cut work. Wi
<mwnaylor>Will have to get used to different syntax.
<cow_2001>does anyone know why would i get https://i.imgur.com/nCSsX8L.png when running guile-studio?
<ron77>hello is it possible to code in scheme with emacs? instead of guile-studio?
<mwnaylor>emacs has geiser and geiser-guile. This gives us a guile repl.
<cow_2001>i expect to get https://kaka.farm/~weechat/guile-studio-1.png but i get https://i.imgur.com/nCSsX8L.png instead
<dsmith-work>sneek, botsnack
<sneek>:)
<mhcat>does guile have something like srfi-197 (chain, like as-> in clojure) currently or planned?
<apteryx>no, but if it's a final srfi, you could try adding it into Guile
<apteryx>(not that I know at least)
<apteryx>what's the best way to find a node in a tree?
<apteryx>given its textual value, say
<apteryx>I know of ((sxpath '(// id)) tree), but not how to filter based on its *text* value
<apteryx>fun, we can't use (if (and-let* ...) fallback)
<apteryx>'or' is ok
<apteryx>see e.g. https://paste.debian.net/1298167/
<rekado>cow_2001: is this when launching with “guix shell --pure”?
<rekado>cow_2001: something may have changed in the way Emacs from Guix sets up the search path.
<cow_2001>rekado: hmm! i'll try it. thank you.