IRC channel logs

2023-11-13.log

back to list of logs

<apteryx>(no, there's a test for it in the guile test suite -- it appears implemented differently)
<apteryx>mirai: your idea to process srfi spec source into texi: https://paste.debian.net/1297999/
<apteryx>it's not finished yet, but already proving useful
<apteryx>caveat: I need to touch up broken HTML sometimes
<apteryx>now the hard part: I need to infer @deffn {Scheme Procedure} ... from <tt>(bitwise-and </tt><em>i</em> ...<tt>)</tt><br />
<haugh>apteryx, be warned that the SRFIs are formatted inconsistently. scraping their HTML is not advisable.
<apteryx>that'll be one good argument when I ask them to use Texinfo ;-)
<apteryx>how can I match a literal '...' using (ice-9 match) ?
<mirai>apteryx: nice!
<haugh>apteryx, (? (λ(x) (eq? x '...)) dots) binds DOTS to the symbol ...
<haugh>good luck with your approach. I too am a little miffed by a standards body outputting unstandardized specifications :/
<isaneran>was just thinking the other day
<sneek>isaneran, you have 1 message!
<sneek>isaneran, apteryx says: see info '(guile-librey) htmlprag)', which mentions both html->shtml and html->sxml
<isaneran>oh
<isaneran>define has the syntactic sugar for (define foo (lambda ...))
<isaneran>with (define (foo ...) ...)
<isaneran>but why doesn't also let have that
<isaneran>(let ((foo (lambda ...))) ..) -> (let (((foo ...) ...)) ...)
<isaneran>feels like that would make the design a bit more consistent
<haugh>isaneran, there are lots of things one might want to do wrt specializing let. For instance, that syntax is used by srfi-71 to express multi-value bindings
<haugh>for more things, see let^ : https://git.gnunet.org/gnunet-scheme.git/tree/gnu/gnunet/utils/hat-let.scm
<isaneran>ah yeah true didn't think about multiple values
<isaneran>let^ looks interesting
<isaneran>though annoying to type on european keyboards
<RhodiumToad>sigh. there are too many competing standards, lets add another one
<isaneran>right so let's not ever discuss the design of current standards
<cow_2001>i have read that in r7rs the library name convention is ( [library name part]+ ) where [library name part] is [identifier] | [uinteger 10], but my guile fails running these commands in ./run.sh: https://kaka.farm/stagit/guile%2Dlibrary%2Dname%2Dconventions/files.html
<cow_2001>maybe i should write that to the mailing list?
<sneek>dsmith-work: Greetings!!
<apteryx>I was hoping to use this pattern with match: (('tt proc) args ... ('tt ")") ('br) . rest) but it doesn't want me to use '...' and '. rest' in the same pattern; are there alternatives, or should I roll my manual "parser" ?
<jpoiret>apteryx: you should be able to use `rest ...` instead of `. rest` no?
<jpoiret>that matches 0 or more
<apteryx>ACTION tries
<apteryx>multiple ellipsis patterns not allowed at same level
<apteryx>ACTION reaches to yet another named let
<jpoiret>it's not at the same level though no?
<apteryx>it is
<apteryx>it's a mostly flat list
<jpoiret>well, not in the above
<jpoiret>oh, that's a ")"?
<apteryx>yes
<jpoiret>i thought it was '')'', my bad
<jpoiret>(whatever that would've meant)
<jpoiret>i guess match is made so that it can avoid backtracking
<apteryx>I think I can't just split the list into 'rows' by splitting on ('tt ")")
<apteryx>and that use match on each "row"
<apteryx>*I can
<apteryx>is FILE expected to be an absolute file name for ,break-at-source FILE LINE ?
<apteryx>it'd be nice if it could use the current module if I don't specify it
<apteryx>the error is not well formatted too: No procedures found at ~a:~a. "snarfi.scm" 118
<apteryx>even if I give it a top level procedure: No procedures found at ~a:~a. "/home/maxim/src/guile/scripts/snarfi.scm" 73
<apteryx>how does this ,bs thing work?
<apteryx>wooh, it's working for SRFI 151
<apteryx>(the snarfi experiment)
<apteryx>here's what it looks like, fully generated from a slightly fixed srfi-151.html spec source: https://paste.debian.net/1298060/
<apteryx>here's the 'snarfi' guild script that generated it: https://paste.debian.net/1298061/