IRC channel logs

2023-11-06.log

back to list of logs

<euouae>Hello does <http://sites.google.com/site/evalapply/eccentric.txt> work for anyone? It's listed at the bottom in <https://www.gnu.org/software/guile/manual/html_node/Syntax-Rules.html>.
<euouae>Someone linked me to <https://www.sigwinch.xyz/misc/jrms_syntax-rules_primer.txt> which seems to be an alternative link. Should the guile manual be updated?
<euouae>and another question, is guile-hall a good project to use for my own guile projects?
<euouae>the project manager
<sneek>chrislck: wb
<apteryx>elevenkb: it doesn't :-/
<apteryx>that's been an annoyance to me as well
<apteryx>(my dirty workaround is to hack it with literal value as you said while testing at the REPL)
<apteryx>is it a parameter? if it was, perhaps you could bind it to what you want
<apteryx>ACTION thinks they found a good solution for the include breakage for relative include during compilation
<apteryx>does touching psyntax.scm means all of Guile's .scm modules need to be rebuilt?
<apteryx>I want to use a fluid or parameter in ice-9/psyntax.scm; where can/should I define it?
<apteryx>it's to use within the 'include' syntax
<apteryx>it's going to be bound in some procedures in (system base compile)
<apteryx>well, that sounds strange to mix parameter and syntax
<apteryx>(include is a macro)
<apteryx>I thougT this may work: https://notabug.org/apteryx/guile/commit/785e6b2577a3698ab63fd594de9d673f4308afde
<apteryx>but it seems the fluid then is akin to a global, and has no 'scope', so it sticks to whatever last value it was set
<apteryx>ah, it's not that strange, include expands to a procedure call (call-with-include-port[0
<apteryx>(call-with-include-port) so if I manage to create my parameter and have it used by ice-9/psyntax.scm it could work, similar to what I tried here: https://notabug.org/apteryx/guile/commit/01206b179fcdfe82284f327050af9d9eae815153
<apteryx>ACTION tries this: https://notabug.org/apteryx/guile/commit/2a45e3984e0bdb2cbcbbaa66c96291556bde2d25
<lisbeths> https://usercontent.irccloud-cdn.com/file/DfX5LN3u/1000020414.jpg
<apteryx>how do I recover from something like this, clearing as little as .go files as possible? Pre-boot error; key: unbound-variable, args: (#f "Unbound variable: ~S" (and=>) #f)make[2]: *** [Makefile:2531: ice-9/psyntax-pp.go] Aborted
<apteryx>this did it: grep --include '*.go' -rl 'and=>' stage0/ice-9/ | xargs rm
<apteryx>civodul: howdy! are you sometimes looking at guile-devel for patches to apply?
<civodul>apteryx: hi! unfortunately not really, as you might have noticed
<civodul>i should switch back to that at some point
<apteryx>ok, no worries :-)
<apteryx>is there someone actively doing that? or is it free style like in Guix, albeit with less hands? :-)
<civodul>review is not something people enjoy doing it seems :-)
<civodul>so yes, very few hands when it comes to review
<apteryx>OK
<apteryx>seems this test is flaky: FAIL: asyncs.test: preemption via sigprof
<apteryx>it passed on a 2nd run
<apteryx>ACTION thought they had sent '[PATCH v5 0/4] Add module depth information to %load-verbosely output' already, but it seems not. Resent it now.
<apteryx>civodul: fyi, the above was made following a tip provided for looking at modules being loaded, noting the limitation that the view was 'flat' :-)
<apteryx>flat no
<apteryx>more
<apteryx>(c.f.: https://lists.gnu.org/archive/html/guile-devel/2023-11/msg00011.html)
<apteryx>I probably should have --in-reply-to to keep a single thread; Maxime offered review comments for prior revisions
<civodul>ah ok
<civodul>i should take a look, but no ETA (esp. with the Guix workshop coming up…)
<apteryx>OK! I'm sure it'll be an enjoyable event!
<civodul>yup!
<apteryx>since the 'include' syntax in psyntax ends up calling a procedure (call-with-include-port), does it mean it calls that at run time?
<apteryx>,expand (include "/tmp/test.scm") doesn't show that
<apteryx>it shows the included contents directly
<apteryx>ah, 'call-with-include-port' is a helper used at expansion time, not run time
<apteryx>it's not part of the output syntax
<apteryx>IIUC
<apteryx>and since include by definition is supposed to expand to the source contents, I don't think it can be made a procedure... hm.
<apteryx>would there be a better way to prevent a .go file embedding a reference to a build source file path than to hack the file port file name in fport_canonicalize_filename (fports.c)
<apteryx>it breaks 'include'
<apteryx>I thought I could capture the original file name in a fluid or parameter but given's include syntactic nature, this doesn't work
<apteryx>ACTION studies scm_i_relativize_path
<apteryx>that's #66046
<apteryx>I replied to that bug with my findings, and failed experiments
<apteryx>where is the source file mapping recorded in the .go? objdump -x doesn't show it
<apteryx>for Chicken: include is documented as "The file is searched for in the current directory and all directories specified by the -include-path option." (see: https://wiki.call-cc.org/man/5/Module%20(chicken%20base)#include)
<apteryx>wingo_: if you can think of an alternative to "add %file-port-name-canonicalization option" (commit 0157a341577223a981d912c93b568792e9dc67e3) that wouldn't mess with 'include', I'm all ears :-)
<apteryx>is the motivation solely to avoid baking a wrong source reference in byte compiled .go files?
<apteryx>does someone know how/where the port filename end up in the bytecode of a .go file?