IRC channel logs

2023-10-31.log

back to list of logs

<elevenkb>Hello there people, I asked a similar question but I want to take it in a different direction?
<elevenkb>Why is it that `current-source-location' returns #f when the file is evaluated in the REPL (by e.g. Geiser)?
<elevenkb>I'd guess that basically Geiser sends a bunch of text over to the repl (basically) and doesn't attach source information at all right?
<isaneran>heyo guilers
<old>elevenkb: I think that source location is only done at expansion time when compiling. To be confirmed
<apteryx>how can I run just a specific test under test-suite/tests/ ?
<apteryx>can I use e.g.: 'make check TESTS=test-suite/tests/srfi-64.test'
<apteryx>mirai: I don't have that mail in my inbox anymore... any way to load it in Gnus and reply to it?
<apteryx>seems if I grok public inbox I could register the
<apteryx>mailing list as an NNTP server
<apteryx>then browse (and reply to) all past communications
<apteryx>ah, I already have gmane.io configured for that, so I can get it from there: nntp://news.gmane.io/gmane.lisp.guile.devel
<apteryx>yes, that does it
<apteryx>mirai: chimed
<apteryx>OK, the correct invocation to run a single test is, e.g.: make check TESTS=test-srfi-4
<daviid>apteryx: in $top_srcdir, ./check-guile srfi-4.test should also 'work'
<dsmith>apteryx, daviid, That's the way I remember running individual tests. With ./check-guile
<tohoyn>I've got a guile program having data files (.ui and .css) in the same directory as the program file. Now I can't read these files from the current working directory since the program may have been launched from another directory. Only solution I have found is to hardcode the program directory into the program file using command like "sed -e 's/@programdir@/$(pwd)/g'". Has anyone else had this kind of a problem? How have you solved it?
<rekado>tohoyn: I use a configure script (with autoconf). It’s not something I would *recommend*, but it’s something that works for me.
<tohoyn>rekado: tx
<tohoyn>perhaps the Linux operating system could be enhanced to handle this kind of problem
<tohoyn>I have tried to use /proc/self/exe but it contains the guile interpreter path for guile script files.
<rekado>tohoyn: in your Guile code you can use current-filename
<rekado>but using it means that you make assumptions about the relative locations of files, and those assumptions may be violated by packagers.
<tohoyn>rekado: current-filename seems to be what I want. tx.