IRC channel logs

2023-10-29.log

back to list of logs

<apteryx>e.g. (call-with-output-string (lambda (port) (with-output-to-port port (lambda _ (display "hello\n")))))
<apteryx>is there a better way to implement this 'read-from-output' procedure? https://paste.debian.net/1296604/
<old>apteryx: I think your procedure is fine
<apteryx>corrected version: https://paste.debian.net/1296605/
<apteryx>OK
<isaneran>hmm
<isaneran>idk why it took me this long but I think I am maybe finally starting to understand continuations
<isaneran>it's like, just, literally the rest of the program
<isaneran>like a fork where the other side of the fork doesn't run in parallel, but might run if it is called
<isaneran>nah okay the other fork does happen after if you don't call
<apteryx>weird, I'm seeing a failure only when using compose: https://paste.debian.net/1296659/
<apteryx>e.g., (package-name (dependency->package+module "coreutils")) -> "coreutils", while ((compose package-name dependency->package+module) "coreutils") -> Wrong number of arguments to #<procedure %package-name-procedure (s)>
<apteryx>any idea what's at cause?
<apteryx>dependency->package+module actually returns 2 values using 'values', but usually when I only care about the 1st one returned that's transparent?
<dthompson>b
<dthompson>oops :)