IRC channel logs

2023-10-25.log

back to list of logs

<old>apteryx: If the log are very important. Put them in a ring buffer in shared memory and let a another process consume them
<old>that is how real tracer does this and not loose any event if the app crashes
<apteryx>RhodiumToad: fun
<apteryx>we're just catching up
<apteryx>old: interesting
<apteryx>shouldn't the spawn example in the manual waipid before reading stdout?
<apteryx>if it's a long running process, otherwise you'd get potentially partial output, no?
<apteryx>*waitpid
<apteryx>spawn is still a lot of boilerplate for something that is probably mundane: https://paste.debian.net/1296098/
<old>hm okay you want something with file descriptor
<old>you can do this on a temporary file
<old>and you need a way to determine from the consumer when the producer is dead
<apteryx>is it safe to rely on USER env variable being set?
<apteryx>seems like not
<apteryx>actual question: how to retrieve the user name of the current process (guile program) ?
<apteryx>s/name/owner/
<apteryx>ah, (getlogin)
<apteryx>is there a way to globally set the logging level for guile-lib (logging logger) library?
<apteryx>seems the interface would want me to disable levels instead of specifying a threshold level? e.g. (disable-log-level! err 'WARN)
<apteryx>that seems ackward; I'd like to accept the log level from the CLI and just e.g. (set-log-level! lgr 'DEBUG)
<apteryx>hm, (enable-log-level! lgr 'INFO) should have done it it seems, but some caveat from the source, about level enable? -> ;; defaults to #t so that if you misspell the log level you get your log
<apteryx>that means that if you want to configure log ERROR, you manually need to disable WARNING, INFO and DEBUG.
<apteryx>Seems inconvenient.
<apteryx>I guess the main gripe I have with it is that the levels are not hierarchical (a "level" is not a true level, it's just a symbol)
<daviid>sneek: later tell tohoyn no it's not a bug, why do you think it is? in the ui dir, scheme files are sxml files, used to generate their *.ui corresponding file ...
<sneek>Okay.
<apteryx>so there's no way to set a global level, you must manually disable each symbol you want out
<apteryx>(want to mask)
<apteryx>other than that annoyance it seems a useful logging library
<lisbeths>pls show le support for le #lambdacalculus irc channel built for geeks by geeks to win and have profit
<apteryx>I have an issue with Hall (guile-hall) where 'hall build -x' in my project crashes: https://paste.debian.net/1296163/
<apteryx>that's on hall 0.4.1 but the code where the crash is is unchanged since
<apteryx>to be triggered you need to *not* be using a $name.scm top level file, where $name is the name of your project
<apteryx>it's for creating Autoconf's AC_CONFIG_SRCDIR
<apteryx>can I use 'hall initiate' to refresh an existing hall project?
<apteryx>hall init --convert
<sneek>wb dsmith-work :)
<dsmith-work>sneek, botsnack
<sneek>:)
<dsmith-work>Hey Hey, Guilers
<tohoyn>daviid: ok. I looked at the code too superficially.
<sneek>Welcome back tohoyn, you have 1 message!
<sneek>tohoyn, daviid says: no it's not a bug, why do you think it is? in the ui dir, scheme files are sxml files, used to generate their *.ui corresponding file ...
<apteryx>is there a way to use something like -*- mode: MODENAME; VAR: VALUE; ... -*- in a Guile script making use of the meta switch on first and second line ?
<apteryx>ACTION tries putting it at the end of the second line as a comment
<apteryx>basically my question is are comments allowed in the meta switch parsed 2nd line
<apteryx>and it seems the answer is no
<apteryx>I've settled for M-x add-file-local-variable for the mode (set to scheme-mode), which gets added as comments to the end of the file and honored by at least Emacs
<apteryx>that's what scripts/hall.in does itself
<apteryx>an executable script cannot be byte compiled directly, right? so the best to do is to split all the script functionality into library modules, byte compile these into .go, and import them in the executable script (program entry point) ?
<old>apteryx: see this: https://paste.sr.ht/~old/6a06feb4a1caafdd60a3334ccc3075e073de6aba
<old>if that can help
<apteryx>guile-hall will automate this for me I think
<apteryx>I've finished splitting my script in modules, which matches hall's expectations better; then even if the main script is not byte compiled it won't matter much
<apteryx>(it can't, as I see it)
<apteryx>since you can't ./main.go, right?
<apteryx>my entry script is now 4 lines: https://paste.debian.net/1296191/
<apteryx>all the rest is byte compiled
<daviid>apteryx: fwiw, that's what i do to, but i keep the main procedure and process the (if any) command line args in the script, then call the app or script 'core' proc ... naming the script without '.scm' extension, installed in $prefix/bin with exec perms -
<dsmith-work>sneek, seen unknown_lamer
<sneek>Sorry, haven't seem 'em.