IRC channel logs

2023-10-19.log

back to list of logs

<rlb>sneek: later tell seeg123456 guile has fdopen, so wonder if (fdopen 1 ...) might be sufficient.
<sneek>Okay.
<mwette>rlb: but guile fdopen generates a port; I think he wants a pointer
<rlb>Oh, right, needs a "real" FILE*...
<rlb>OK, nvm.
<rlb>(and thanks)
<rlb>sneek: later tell seeg123456 maybe nevermind? I wasn't thinking about needing a "real" FILE*.
<sneek>Got it.
<sneek>Yey! dsmith-work is back
<dsmith>sneek, botsnack
<sneek>:)
<mwette>civodul: thanks for the fix
<civodul>yw!
<apteryx>can I compare regexp and string objects using eq? or should I use eqv?
<apteryx>seems eq? should be enough
<apteryx>hm, eqv? or eq? doesn't work on strings
<dsmith>eq? is basically comparing the address of a thing
<dsmith>You probably want string=?
<lilyp>yeah and comparisons between regexps and strings should be done through the search and match functions
<apteryx>the use case is special, I'm not interested in executing the regexp, just comparing their objects
<apteryx>how can I most simply unbox values, from a variable? can I use srfi-71 and do (let ((first second third *values-variable*)) ...) ?
<apteryx>nope
<apteryx>seems I can't bind 'values' to a single variable?
<apteryx>I guess that's the point of value
<apteryx>can I use a multi-valued result with fold?
<mwette>(sxml fold) provides fold-values
<apteryx>I also see fold2 in (guix combinators)
<apteryx>any example using fold-values?
<apteryx>I think I'm mistaking values for some container object; it's not, right? it's just a way to return multiple individual values?
<seeg123456>is there a function to parse uri query string or do i have to do it by hand?
<sneek>seeg123456, you have 2 messages!
<sneek>seeg123456, rlb says: guile has fdopen, so wonder if (fdopen 1 ...) might be sufficient.
<sneek>seeg123456, rlb says: maybe nevermind? I wasn't thinking about needing a "real" FILE*.
<seeg123456>there is the (web uri) module but i can only get (uri-query uri) here and it's a string
<seeg123456>"a=1&b=2" etc
<mwette>It is not a container. I look at it as a message to the compiler to set up passing multiple values to the continuation (e.g., receiving procedure)
<apteryx>thanks
<mwette>apteryx: https://wingolog.org/pub/fold-and-xml-transformation.pdf
<apteryx>I think I've burnt a couple cells before reading that paper :-)
<gnucode>dsmith: were you looking for me?
<sneek>Welcome back gnucode, you have 1 message!
<sneek>gnucode, azert says: that I think sneek is fun
<gnucode>sneek help
<dsmith>sneek, later tell wingo flubt
<sneek>Okay.