IRC channel logs

2023-10-13.log

back to list of logs

<sneek>dsmith: wb!!
<graywolf>Heh, when I asked about the problem with ftw, it turns out I used it in a correct way. It is just that the guile compiles in the getuid and getgid values used during the compilation (of guile). So it makes sense that ftw thinks it cannot entry the directory with 0700 owned by my user...
<sneek>Welcome back dsmith-work!!
<dsmith-work>Happy Friday, Guilers!
<dsmith-work>sneek, botsnack
<sneek>:)
<mwette>graywolf: You are right about that. Here at line 55 it loads my uid: https://paste.debian.net/1294956/
<mwette>disassembly of my own-built guile; looks like a bug
<dthompson>system crafters will be livestreaming about guile-hoot today, for anyone who is interested. details here: https://fosstodon.org/@daviwil/111227316301869374
<dthompson>stream starts in about 1 hour 15 minutes
<graywolf>mwette: Yeah I reached the same conclusion https://debbugs.gnu.org/cgi/bugreport.cgi?bug=55344#14 . The ,xx is very handy.
<graywolf>I have no idea *why* it does happen.
<graywolf>Hm, I wonder why getuid-or-false is a macro.
<graywolf>wait, what does macro without '() even do? Like, how does (define-macro (foo) (...)) and (define-macro (foo) '(...)) differ?
<dthompson>system crafters stream is live! https://www.youtube.com/watch?v=Vd9zooWMOsM
<dthompson>myself, cwebber, and robin from spritely will be appearing shortly :)
<civodul>ACTION tunes in
<civodul>itโ€™s frozen!
<civodul>but i can see your faces :-)
<civodul>works on https://www.youtube.com/watch?v=_29duXYFi8s ๐Ÿ‘
<graywolf>When I send a patch fixing a bug, should it go to the NUMBER@debbugs.gnu.org or bug-guile@gnu.org or is there a separate address for patches?
<civodul>to bug-guile@gnu.org
<graywolf>mwette: fyi https://debbugs.gnu.org/cgi/bugreport.cgi?bug=66531
<mwette>graywolf: I think the macro needs an eval-when set-up
<RhodiumToad>it needs to not be a defmacro, or it needs to quote its expansion of (getuid) etc.
<RhodiumToad>as written the whole macro executes at compile time and substitutes a constant datum into the expansion
<RhodiumToad>it could have been for example (if (defined? 'getuid) '(getuid) #f) instead
<RhodiumToad>graywolf: given (define-macro (foo) (...)) then (foo) evaluates the (...) and its result replaces the (foo) form
<RhodiumToad>ACTION wonders why on earth it is a defmacro rather than a syntax rule
<RhodiumToad>jeez, committed in 2021 and nobody noticed?
<dthompson>oof
<dsmith-work>Need to provide a mild electric shock whenever writing new code using defmacro.. You can still do it, but it should be.. uncomfortable.
<dthompson>defmarco and defpolo is this anything?
<RhodiumToad>maybe (define-syntax getuid-or-false (if (defined? 'getuid) (syntax-rules () ((_) (getuid))) (syntax-rules () ((_) #f))))
<RhodiumToad>that keeps the defined? check at compile time