IRC channel logs

2023-08-29.log

back to list of logs

<daviid>RhodiumToad: i pushed a few other fixes, that the adw1-demo port (wip) triggered, some releated to the <gdk-surface> and renderer for a user session, which depends on the user session backend ...
<daviid>RhodiumToad: i also pushed an updated version of the 'About Adwaita Demo' dialog (that calls those 'fixes') - it would be nice if you could pull and see if everything is ok on your side ... when times alow ...
<daviid>RhodiumToad: pull/make ... then run the demo, open the about adwaita demo dialog->troubleshooting->Debugging Information .., see if it works (and if the info reported there is accurate wrt your environement ...) - thanks
<RhodiumToad>seems to work
<daviid>RhodiumToad: oh, so fast :) - thanks
<RhodiumToad>"Code name: - not available - " what's that?
<daviid>RhodiumToad: in debian, it's the release code name, trixie here ...
<RhodiumToad>oh right
<RhodiumToad>not applicable to freebsd then
<daviid>right, and here the version is not available ...
<RhodiumToad>"- Desktop: #f" "- Session: #f (#f)" presumably this is looking for some gnome desktop environment stuff that's not active here
<daviid>i copied the 'upstream' code for thoese, they are the XDG_CURRENT_DESKTOP, XDG_SESSION_DESKTOP and XDG_SESSION_TYPE env var content
<RhodiumToad>ok, those aren't set in this case
<daviid>are these not in freebsd?
<RhodiumToad>I'm not using a desktop environment. if I were, they would likely be set.
<daviid>hum, do you think i should check and also displao 'not available - ?
<daviid>not a big deal though ... but ...
<RhodiumToad>up to you
<daviid>ok
<RhodiumToad>it correctly detects the backend and renderer
<RhodiumToad>(X11 / Cairo)
<daviid>perfect
<daviid>RhodiumToad: if all goes well, i should release 0.8.0-a.5 tonight, or tomorrow night ...
<RhodiumToad>ok
<haugh>Anybody comfortable with extending SRFI-42? I would love an example of how to compose first-ec with fold{,3}-ec in order to bake early termination into a custom comp.
<haugh>although maybe this is a good domain for prompts
<daviid>RhodiumToad: does 'make check' always pass on your side? here, in the test-suite subdir, (tests hl-api) module, all tests used to be fine, but recently (what ever that means, i can't spot what changed/when, probably something in guile latest, the test-g-timeout-add sometime pass sometime hangs (no crash, it just never finishes/returns)
<RhodiumToad>I hadn't run the tests
<RhodiumToad>ACTION kicks off a build of clutter-gtk3
<daviid>RhodiumToad: oh, i have to get rid of clutter - but gtk3 will always be mandatory in the tests, because of the override modules ..
<RhodiumToad>gtk3 isn't a problem since I have tons of other stuff depending on it
<gnucode>are ya'll trying to create gtk apps via guile?
<daviid>- the clutter dependency is a pita, historical reasons ...
<RhodiumToad>gnucode: yes
<daviid>RhodiumToad: i said guile latest, maybe it's a GLib latest 'thing', fwiw, the previous test-g-idle-add, nor the following test-g-timeout-add-seconds tests never hang - they all use the same 'test pattern' which is to define a loop, a iddle and launch the loop in separate thread [ gtk is single threaded, but i think it should be ok, as long as the loop and the iddle are defined, then runin a single thread ... but maybe not, need to
<daviid>investigate ...]
<daviid>gnucode: examples here https://www.gnu.org/software/g-golf/learn.html - including, at the bottom, a newly added libadwaita [adaptive UI [by purism ...]
<RhodiumToad>tests pass on the guile version I'm using, which is not latest but 3.0.9 plus necessary patches for freebsd
<daviid>RhodiumToad: ok thanks - it could be that it hangs if you try a couple of times ...
<RhodiumToad>tried 4 times so far
<RhodiumToad>no hangs
<daviid>great - what's going on here :) ?
<daviid>i wonder if my test pattern for a loop and a iddle, which i define in the main thread but launch in another thread (knowing gtk is single threaded) is ok or meant to fail - i'll ask in #gtk - here, make distcheck systematically fails now ...
<daviid>if/when i coment just that test, and keep the test-g-idle-add and test-g-timeout-add-seconds - it always pass
<daviid>RhodiumToad: i asked in #gtk, fwiw ...
<daviid>if i change the definition of g-timeout-add for this - https://paste.centos.org/view/469ea73e - then the test-suite pass
<daviid>i'll do that for all three defs - i believe guile's compiler optimizes and get rid of those steps ...
<daviid>RhodiumToad: that's not it, more about this on #gtk if you are interested ...
<daviid>i am going to coment those 3 tests [ just keep their test code, to manually run one-by-one if i need to .. ]
<flatwhatson>abcdw: get-string-all :)
<jpoiret>I'm not very familiar with guile compilation: how useful is it to have the modules that are used by the file you're compiling at compile time? what happens if all of those dependencies are autoloaded and I provide "blank" files instead
<flatwhatson>cross-module inlining was introduced in recent versions, that would require modules to be loaded at compile-time
<jpoiret>right, but would it fundamentally break anything? I don't believe not having cross-module inlining would have a significant performance impacts for these anyways
<ArneBab>wingo: Andrew Tropin did some live dev with Fibers today: https://www.youtube.com/watch?v=FH8IGYUyWVc
<apteryx>is a way to extract the textual regexp out of a regexp object?
<rlb>apteryx: if I recall correctly, no. I ended up creating a new structure to hold both.
<apteryx>I see