IRC channel logs

2023-08-17.log

back to list of logs

<mwette>rlb: I'm reviewing. It make take some time. A tidbit: li 2046 allocs to MAX_UTF_.. (not +1?) vs pass 16 to utf_enciding_name on li 2054 -- issue?
<mwette>
<mwette>^ bytevectors.c
<rlb>mwette: hmm, if I'm understanding right, I think that's just my manual expansion of the original macro (i.e. when I replaced the macro). e.g. on main that value comes in via the _utf_width arg in STRING_TO_UTF (16). So I just kept the 16 there as-is.
<rlb>i.e. didn't even think about it, assumed main was correct.
<rlb>(and thanks for taking a look :) )
<rlb>(Oh, and I expanded the macro in-place (more or less) because it was only needed once.)
<mwette>rlb: Got it. I'm not digging very deep.
<rlb>No worries.
<rlb>(Just wanted to double-check the risk -- that proposal includes a *lot* of easily off-by-one C code...)
<wingo>good day / month / etc :)
<wingo>good day civodul
<civodul>hey wingo
<jas>hi! what tools do people use to indent guile code? the only thing I've found is using emacs in batch-mode: https://github.com/spk121/guile-gi/blob/master/indent-code.el
<civodul>jas: hi! Emacs is best, but you can also try 'guix style'
<jas>civodul: thanks! is 'guix style' safe to use for files that aren't guix package definitions?
<jas>btw, 'guix style' doesn't handle ISO-8859-1 files well
<civodul>if you have a "coding:" declaration, it should be fine no?
<civodul>and yes, it should mostly work for non-Guix Scheme code, though certainly you'll find that some things need tweaking
<jas>no, coding: latin-1 doesn't help, try (in guile-gnutls master): guix style -f guile/modules/gnutls/extra.scm
<civodul>"coding: iso-8859-1" maybe?
<civodul>though really, these files should be UTF-8 :-)
<jas>the files uses a Local Variables at the end. changing to iso-8859-1 doesn't seem to help
<jas>I'll recode them as UTF-8
<jas>which caused 'iconv' to crash on my system.... endless rabbit holes
<civodul>heh
<jas>seems like 'guix style -f' is not idempotent
<jas>and it re-formats whitespace in comments. emacs indentation seems a bit careful
<civodul>whitespace in comments? only for margin comments i guess, like ";this"
<jas>yes, but sometimes comments use internal indentation, like this: LINE1: ' ;; 1. foo bar baz'. LINE2: ' ;; baz bar'
<jas>guix style -f rewrites LINE2 as ' ;; baz bar'
<jas>i'll see if I can get emacs indentation to work for guile-gnutls. it is more likely to match developer editors too
<wingo>i am going to merge in some code to let the backend of the CPS optimizer use target-specific passes
<wingo>for guile-vm there are a few canonical passes that are currently run. for the wasm/gc target i will have some out-of-tree passes; out-of-tree so that we can make mistakes faster :P
<wingo>civodul: regarding recent commit to r5rs.texi, wdyt if i revert it? it's a historical document that others rely on so probably we shouldn't change it
<wingo>ACTION recalls when i burned my fingers on that back in 7fb9c4aff29daab35d0726bac58f8fbd6bd2e26c
<civodul>wingo: you mean reverting c7d170c5d1e90de64962d4cf3cb257364f77b08f ? sure
<civodul>yeah it makes sense to keep it as-is, i hadn't noticed
<wingo>civodul: i would just revert the changes to r5rs.texi
<wingo>but yeah, cool