IRC channel logs

2023-08-05.log

back to list of logs

<rlb>wingo: wondering if we may actually want to keep stringbuf null termination if (as I am currently) we have some broader categories of things like symbols be backed by independent stringbufs.
<rlb>Without null termination there, we'll have to allocate/copy/terminate every time we want to pass one of them to some guile or external function that doesn't provide a "stringn" variant.
<RhodiumToad>keeping null termination will save a lot of pain
<rlb>Strings still won't be, necessarily, so it's just an optimization. Though I'm also contemplating the possibility that independent strings (not shared) might be more common/desirable in with utf-8.
<rlb>read-only (immutable) and independent, I mean.
<rlb>But for that to work well we'll need some variants of common functions/modules, i.e. some hypothetical (srfi srfi-13 immutable) or whatever, that gives you functions like string-filter that return a read-only string, not a mutable string. This is in part because if we did that, we could make those strings even more efficient than currently, i.e. they can be fully "in-line" cache-wise, etc. (they're ally just *be* stringbuffers as a new
<rlb>string variant.
<rlb>I think that's pretty easy to arrange (fsvo easy) on top of the current work, so I've been toying with the idea.