IRC channel logs

2023-07-31.log

back to list of logs

<rlb>suspect we have some concurrency issues in our symbol creation, i.e. what if the string changes between checking the hash and creating the symbol...
<rlb>ACTION fixes it in the utf-8 branch (at least -- assuming that's right)
<rlb>The utf-8 stuff is less sensitive since it's easy to work from snapshots if you remember to.
<rlb>wingo: we may have a good number of places that expect null termination. I keep hitting bits that make me wonder. e.g. canonicalize_encoding, currently.
<shawnw>Has anyone packaged SRFI-130 for guile?
<rlb>wingo: we'll need to start leaning toward "str, n" api signatures if we're dropping null termination and we don't want to have to create a lot of scm_gc_strndup() temps.
<janneke>b
<mwnaylor>Is there an online repository for guile code that can easily be installed? I'm thinking of something like chicken with 'chicken-install' and racket with 'raco install'.
<mwnaylor>I'm trying to pick a lisp that works well from emacs. I had ssl errors trying to install code w/ raco. Which chicken, I get errors when attempting 'geiser-eval-buffer'. I may fall back on guile, since it seems that geiser works best with that dialect.
<janneke>mwnaylor: i think guix has become the defacto guile installer program (amongst other things ;)
<haugh>RIP
<distopico>guix install guile-... Is the way
<sevan>raised a bug report regarding date(1) - 64984, and someone had already raised a bug report regarding redefinitions, requiring a C11 compiler to build Guile, so I followed up there: 41467
<sevan>Was going to follow up about the big endian image but I'm going to try the changes in https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214 first to see.
<rlb>...I've been assuming c99 lately, but not entirely certain that's correct.