IRC channel logs

2023-07-25.log

back to list of logs

<rlb>mala: haven't looked at it carefully, and don't know offhand exactly what's preventing your code from working, but in case you hadn't found it - https://www.draketo.de/software/guile-capture-stdout-stderr.html
<mala>rlb, gosh that is both useful and kind of terrifyingly complex
<rlb>I suppose subprocesses are generally somewhat tricky, but not sure if there's any simpler approach for this case (in part, since I still haven't investigated why your attempt didn't work)...
<jpoiret>mala: your with-error-to-port redirects current-error-port to a port that is not backed by a file descriptor, and thus will get dropped and replaced by /dev/null when spawning a sub-process
<jpoiret>you need to open a pipe instead
<chrislck>sneek: botsnack
<sneek>:)
<chrislck>\o/ \o/
<unmatched-paren>does guile provide constants for pi and e anywhere in the standard library? searching the manual for / pi / and /euler/ turns up nothing of use
<unmatched-paren>or do i just define them myself as approximations?
<unmatched-paren>one of the manual's examples contains a (define pi 3.14...) line, so i'm guessing so
<dthompson>unmatched-paren: nothing defined in guile. I define them in my own projects when needed.
<RhodiumToad>how precise do you want the value? :-)
<RhodiumToad>(* 4 (atan 1)) is likely good enough for most purposes
<dthompson>guile's partial evaluator compiles (* 4.0 (atan 1.0)) to 3.141592653589793 :)
<RhodiumToad>which is correct to that number of decimals...
<dthompson>just a fun fact that peval handles trig functions :)
<unmatched-paren>i don't really need it incredibly precise, but that atan approximation is good to know
<unmatched-paren>(i'm just messing about in the repl, really)
<unmatched-paren>thanks
<RhodiumToad>the atan result should be as precise as the representation allows, in this case it's representing an inexact number using a 64-bit float
<RhodiumToad>(acos -1) is also available
<RhodiumToad>hm. there's no builtin way to do a square root with better precision than floats?
<mala>jpoiret, thank you!
<sevan>hi, I've almost got Guile 3.0.9 built on ancient OS X 10.4 running on powerpc. I have 2 questions, does Guile intentionally require a compiler with C11 support? (it has a redefinitions support requirement which C99 compiler will lack). I'm currently stuck on how to provide an implementation of dprintf(3) or if it's necessary, build gets to linking libguile-3.0.la and breaks since it's not there on ancient OS
<sevan>X. I see an m4/stdio_h.m4 which is meant to check for its declaration but I don't see anything in config.log
<sevan>I'm building with GCC 5.5 which has C11 support, since GCC 4.0.1 supplied by Apple only support C99 and so chokes a couple of places where libguile/scm.h is imported and there's a redefinition in the file importing.