IRC channel logs

2023-07-07.log

back to list of logs

<ArneBab>mfiano: I have the same feeling, yes
<ArneBab>mfiano: I think it would be good to take a birds-eye view of programming with Guile and seeing what we need to provide by default to make the initial user experience seamless.
<spk121>wingo: guile's lightening is quite different from current upstream GNU lightning. I was trying to see if any bugfixes upstream needed to be pulled in to guile, but they are hard to compare side-by-side.
<spk121>but I did find that if I take guile's lightening and make all the "#if __CYGWIN__" into "#if __CYGWIN__ || _WIN32", then JIT almost works on Woe32
<spk121>now that I have JIT not attempting to run at random locations in memory, there's a stack buffer overflow. sigh
<lechner>Hi, does 'procedure-source' work for anyone? An example would be appreciated. Thanks!
<janneke>spk121: shouldn't that be #if __CYGWIN__ || __MINGW32__ ?
<janneke>very good news, tho!
<spk121>janneke: actually no. Cygwin no longer defines _WIN32, but, _WIN32 covers all the other non-Cygwin cases including MINGW
<dthompson>lechner: that seems to use the old source properties interface. my understanding is that it's obsolete at this point. you can use program-sources from (system vm program) instead.
<dthompson>that returns a list of source objects. the first one seems to be the entry point to the procedure.
<lechner>dthompson / thanks for the hint! the result looks like a bunch of ice-9/eval's, however, and not like a procedure's code. maybe i misunderstood what those procedures do
<dthompson>lechner: you won't get the code itself out. you'll get pointers to the source files.
<janneke>spk121: ah, ok
<lechner>dthompson / thanks! is there a way to get the code for an anonymous lambda?
<lechner>a thunk
<dthompson>lechner: there's no way to get the original expression tree, as far as I know. all I've ever seen when looking at the compiler code is references to file/line/column info.
<dthompson>the macro expander passes that info along to Tree-IL, who passes it along to CPS, who passes it along to bytecode.
<lechner>dthompson / okay, thanks!