IRC channel logs

2023-07-01.log

back to list of logs

<rlb>wingo: wrt the u32<-scm-sz string-ref intrinsic, I've tried a few things, but keep hitting "Multiple differing values and no meet procedure defined u64 scm" in allocate-slots. Imagine I'm just missing some bit, but don't know what. Also should I need to define u32<-scm too or extend the just wrt u32 at all? (I *think* I should just use u64 in the vm there...)
<rlb>That error when trying to build stage1 boot-9, fwiw.
<rlb>For now (until that's figured out) I'll see if I can just drop the string-ref/set! optimizations in compile-cps and lower-primcalls (as before with just compile-cps before the split) so I can get back to the actual utf-8 work before I forget where I was :)
<rlb>wingo: also fwiw, I *think* I'm on the commit that completely changes the internal rep to utf-8 (though some functions still operate from a throwaway, gc-allocated scm_wide_chars() at this point in the series), and it's not crashing anymore, even though the wide-oriented lower-primcalls are still there. Might just be a mistake/misunderstanding on my part, but I'm pretty sure it did crash before this rebase onto current main, where
<rlb>those calls moved to lower-primcalls. Wouldn't say that's alarming atm, since it's most likely my fault, but it is at least confusing.
<rlb>Ahh, so forcing a crash in the string-ref lowerer does cause it to crash during the build. Wonder if what's going on is that we just don't do anything dangerous (enough) in the current tree during a bootstrap make check, to crash that code, i.e. maybe most/all strings that get there are ascii, or the corruption isn't bad enough to crash it...
<rlb>(...during the build, so it isn't just ignoring it.)