IRC channel logs

2023-06-29.log

back to list of logs

<rlb>wingo: wrt 'u32<-scm-sz' I don't see any other '<-' intrinsics. Is that expected? And I'm not really sure I understand all of this well, in all the various places. Worst case, could I just disable the string optimizations for now somehow, and come back to them later?
<rlb>I do see '<-' operations in vm-engine.c if that's what you meant, though my comment about not completely understanding things well yet definitely still stands.
<mwette>rlb: e.g., I see call-scm<-u64 in sec 9.3.7.7 of the manual
<rlb>wingo: I suppose if it were feasible, one optimization might be some batching of multiple "adjacent" string refs, though certainly more beneficial for ascii-only.
<rlb>...even if so, not sure how commonly that'd be worth it vs "other approaches".
<rlb>...might have to augment jit.c too? i.e. wrt u32<-scm-sz
<rlb>..huh, why is size_t represented as uint32_t in the jit, or rather, why is that OK?
<dalepsmith>When you use ... in a pattern you need to use it in the template
<dalepsmith>sneek, botsnack
<sneek>:)
<dalepsmith>Also, it means "zero or more". Will your macro work with no "args" values? No.
<dalepsmith>Do you want to define many times? Put a ... after the define form.
<dalepsmith>Also, I bet you are on matrix. Your messages are not showing up in IRC. Need to identify with nickserv
<dalepsmith>The #guile channel requires you to identify for messages to be seen.
<dalepsmith>Keeps the spam down I guess
<dalepsmith>sneek, rember matix is https://libera.chat/guides/faq#can-i-connect-with-matrix
<dalepsmith>sneek, remember matix is https://libera.chat/guides/faq#can-i-connect-with-matrix
<dalepsmith>sneek, matix is https://libera.chat/guides/faq#can-i-connect-with-matrix
<sneek>Understood.
<dalepsmith>Bah. Can't type at all today.
<dalepsmith>sneek forget matix
<sneek>Okay.
<dalepsmith>sneek, matrix is https://libera.chat/guides/faq#can-i-connect-with-matrix
<sneek>Okay.
<dalepsmith>sneek, matrix?
<sneek>Last time I checked matrix is https://libera.chat/guides/faq#can-i-connect-with-matrix
<dalepsmith>Goodbot
<mirai>is there a call-with-port analogue but for pipes?
<mirai>from what I understood, call-with-port uses close-port; while this can be used to close a pipe, it's not the same as doing a close-pipe since close-port doesn't reap the child process
<civodul>mirai: there's no equivalent for pipes, you have to roll your own
<mirai>civodul: would it be worthwhile to add a call-with-pipe variant in Guile?
<civodul>not sure, in some cases 'spawn' might be better
<janneke>i'm sure gash has code to setup a pipeline
<civodul>right, and there's also 'pipeline' in (ice-9 popen), which i think +/- comes from Gash
<mirai>The idea is to condense the snippet documented in open-input-pipe into something like “(call-with-port (open-input-pipe "date --utc") read-line)”
<civodul>(contributed by Rutger)
<mirai>call-with-pipe I mean
<civodul>the tricky part is how to handle non-local exits